Creating AppVM

I’m very new to Qube OS.
I did an OEM factory reset, setup my login credentials.
But I’m unable to create a personal:Firefox VM.

I get an error message that PCI device dom0:01_00.0 does not exist.

I checked out the QubeOS documentation and didn’t find anything.

It seems like the personal template may need its settings changed.

Thank you.

Hi, welcome to Qubes.
You haven’t said how you tried to create the qube.
The simplest way is : qvm-create personal <-t TEMPLATE_TO_USE> -l COLOR

If you want to recreate the default personal qube, then run:
sudo qubesctl state.apply qvm.personal

Neither of these will allocate a PCI device.

I never presume to speak for the Qubes team. When I comment in the Forum or in the mailing lists I speak for myself.

I used the UI (xfce?). I clicked on App Menu → Qube: personal → personal: Firefox.

I get the PCI device0:01_00.0 does not exist message.

If i go to App Menu-> Qube: personal → personal: Qube Settings → Devices tab, I don’t see any devices selected.

I will try the cmd line you suggested.


You’re probably seeing this error not for your personal VM but for sys-net VM. So check the Devices tab in Qubes Settings for sys-net.
If your personal VM has sys-net as networking VM (or sys-firewall as networking VM and sys-firewall has sys-net as networking VM) and sys-net is not running when you’re starting personal VM then QubesOS will first start its networking VM sys-net.

OK - the problem is not with creating the personal qube, but in
starting it.
If you set the netvm to none (Settings->Basic->“Net qube”), are you able
to start firefox then?
If so, then the issue lies with the netvm , probably sys-firewall, or

See if you can start either of them, and check the Devices allocated
to them.

I never presume to speak for the Qubes team. When I comment in the Forum or in the mailing lists I speak for myself.

Thank you for the prompt responses.

I set the NetVM to none, in the Qubes:personal settings and i could start the VM with Firefox.

The sys-firewall settings has netVM set to sys-net.
And sys- net has netVM set to none.

The sys-net Settings-> Devices tab has the 01:00_0 Unknown device in the Selected box on the right. I believe this unknown device is causing the errors.

When I unselected the unknown device, I was able to get my personal:Firefox qubes to start !

My next step is to connect this VM to the sys-usb so i can get access to my local home network.


You are right. The sys-net had the offending unknown device under its Settings->Devices tab. The unknown device was selected.

Once i deselected this device I got the Qubes:personal Firefox to run.

Thank you!

1 Like