Couple or three, hopefully fairly straightforward, questions

First of all, I acknowledge that the intent of the Qubes design philosophy is for users to learn how to do things for themselves, and take non-qubes specific to other forums so that this site and its more programmatically-able members are not overwhelmed with a deluge of technical questions. Indeed I kinda like that, I want to learn how to do stuff for myself pertaining to linux, I always have, its just that the home-pc revolution aka W95’s release was just after I left school and with workplace commitments I have never really find the time to sit down and work out how to do things outside of a Windows-type environment.

But at the same time, sometimes I run into roadblocks and I simply don’t understand if there is a problem with what I am doing or a problem with my understanding of what I am trying to do. These past two nights, for example, I have probably spent a total of about 20h (or more) trying to work out the answers to two questionswhich seem like they should have fairly straightforward answers. Sometimes the guides on this website and others dont quite make sense. Perhaps a utility does not work as stated, or cannot be downloaded. Or perhaps even part of the solution on the forums is missing. And I find myself questioning whether this has been done deliberately, as a pseudo-training exercise to enforce learning.

So thats question one I suppose, apologies for my verbosity, are the guides sometimes deliberately incomplete so as to force users like myself how to learn to do things better? Cos it doesnt seem like the two questions below should need my coming to the forums to ask them. But at the same time, I’ve really tried to work the answers out for myself and I simply cannot resolve them.

So question 1 is related to Fedora 38 updates which, since installing my PROD server yesterday I have been unable to do. I get a curl 56 error which I have worked out seems to be a problem with the proxy server that the dnf.conf file in /etc/dnf is (not) directed to. I have tried redirecting my searches to a different fedora mirror for example or several other amendments to the syntext to makethe mirrorlink to redirect its update requests elsewhere. Ad to be clear there is about 700mb to update, there is a lot I need. Anyway, in the dnf.conf file it looks as if the proxy server has been hashed out? (that might not have been the word used, but made to be inactive is what I mean). And then I spent many hours tryong to work out how to do that. At first I tried to gedit as one of the guides on here suggested. But the tool wasnt installed on Fedora, and I couldnt install it because, well, as already stated there was an issue with the mirror from which I dnf got its updates. Then I tried to use nano, which was installed, but couldnt overcome the restrictions placed on the file about ‘write’ permission. And those were the easy bits. I then spent several hours fiddling around with chmod, At some point I realised that I seemed to have confused chmod with chown, and indeed was trying to the syntax for each interchangeably. This led to much swearing and self abuse. I then realised that both tools were needed, and fiddled around until I got the queries for both to enact without throwing up errors (don’t even get me started on how long it took me to work out what my username was for chown). Even now I am not sure how I learned how to use the tools so much as learned how to overcome them. But my edits to the damn config file simply would not save so that my new install could dl the updates as per the stated qubes install procedure. Eventually some post on some forum seemed to say it might be a problem with how the drive in which the file was installed is mounted, although I couldnt work out if that was true or not. At that point, at approx 8am, I gave up and went to bed thinking about perhaps just downloading the F39 testing template and using that instead, even though I knew that was not a good idea.

The second question, despite seeming more technical, I did originally manage to overcome. On my test install. But when I tried to replicate this on my prod install (after giving up on q1 this morning thinking it would be a quick win before bed time) I could not get it to work. This could be because I downloaded the wrong version by mistake for the prod install (v14 rather than v13.4). Or it could be because of any number of minor things which I had done to my test install the previous day before I eventually got it to work. The purpose fo this task was to install FreeBSD (well actually, to install OPNSense but I never got that far). I wanted to install it as a template so that I could run two instances of it, one as a firewall/gateway/vpn vehicle for my qubes install, with a view to eventually moving it to my home server/a device of its own when I was comfortable with using it. The second instance I planned to use as a usenet/torrent media dl server. perhaps for squid too which kept on coming up as a proxy server. Again for my homeserver when I eventually build it, cos that way I could use the template to reinstall should my fiddling bork up either of the production use cases. It seemed like it would be a straightforward process if I created an ova file for virtualbox and then ported it across, even though it was described as being for ‘advanced’ users. I had used virtualbox before I cam to Qubes and found it by comparison much more strtaightforward albeit reliant on the OS from I wished to escape, ‘how hard can it be?’ I remnember thinking.

Well, as it turns out, very. But the difficulty seemed seemed to be rooted in the instructions not really matchingh reality. For example, the docs I got from vboxmanager werent zipped up and it kept on giving me a vdi instead of a vdmk file although I did eventually manage to get all the files ported from my windows laptop to my qubes desktop. But I remember qemu didnt seem to be working in the way that instructions implied. It took a long while to convert my vdmk file into a raw file, from googling it seems as if maybe the syntext for such is not as it once was, I think I ended up using a vdi file cos vdmk wasnt recognised? Certainly not as the instructions state on the qubes forum state they should. I remember then turning my attention to the ova file, seemingly the meat and potatoes of the entire install only to discover that there are no further instructions for the ova file beyond extracting it from a tar archive. And when I couldnt work out how to, paw it inside the raw file? I sortta just gave up and went back to the original plan (before I found the instructions) which was to just install the damn thing. Which to my surprise worked almost straight off, although when I tried to replicate that this morning did not. Besides the fact I used the wrong version, I think maybe the raw file was still inside the shell template when I installed 13.4, either that or i changed something else that I do’t recall. but whenever i tried to install v14 this morning directly onto the template the server would boot up and then immeduiately shut down regardless of whether I set it up as a PV, a PVH, or a HVM (I think it is supposed to be PV because I remember readibng something about paravirtualisation, I also thought it could be HVM because it needed a ethernet cardalthough it couldnt be online at the sametime as sys-net).

So any advice you can offer to resolve these two issues would be appreciated. and like i say, is it purposeful that things seem not to work in the way that muight be expected so that i/we learn from it?

Best, TMK.

Updating fedora-38-xfce

Error: Failed to download metadata for repo ‘updates’: Cannot prepare internal mirrorlist: Curl error (56): Failure when receiving data from the peer for [Proxy CONNECT aborted]

^^re question 2. Also, why does global/local copy paste only ever seem to work about half the time? it is incredibly frustrating. I mean, I’d rather have some sort of air gapped clipboard-qube into which only unformatted text and anonymised images could be copied in and out of than the present system. it would probably take less clicks to do too.

also, is there a way for me to put vm’s into folders so as to unclutter my VM manager screen? i know it is a feature that has been requested many times, but the requests always seem to be closed as resolved without a resolution being provided.

I would be surprised if anyone is intentionally doing this. But people do have to make judgement calls about what information should be assumed to be commonly understood vs explained.

How are you applying the update? Unless you have created an atypical configuration, the GUI tool (which should create an icon with an up arrow in the toolbar when updates are available, otherwise can be opened from the app menu as “Qubes Update”) should “just work”.

While I haven’t tried FreeBSD, when I want to run an unsupported OS I normally create a standalone HVM and use the “normal” installer ISO, and haven’t run into problems yet.

Since you mentioned installing FreeBSD, it’s worth mentioning that global copy/paste requires support from the VM, so if you’re trying to use it from an unsupported OS then it’s not expected to work. Otherwise I’m not sure why you would have that problem.

1 Like

Forgot to mention, I don’t know if this suits your needs but I found that the manager was a lot easier to navigate once I realized that you can sort on the column that shows the type of Qube (single box for AppVM, double box for template, etc). That way all of the sys-* and template VMs are sorted at the bottom, and the AppVMs are at the top (second only to dom0, because of course dom0 is first :slightly_smiling_face:).

I havent done it in any different way at all. The rest of them are updating just fine, it is solely the fedoras template that is not working, regardless of wherther i do it from the qubes update manager or directly on the template.

Yeah well, like I say, that was the original intention. Then I saw the instructions on the wubes forum and figured that would be as better way to do it, and then when i went back to the original plan it worked. the first time. then the second it did not.

if u had looked at the instructions i linked it seems as if there is a chunk missing given u dont get told to do anything with the ova file after unzipping it. and the ova file is the largest part of the matter. the instructions also seem to imply that they would work for anything for which there is a template on VB (see below, highlighted the important bit).

You can convert >any< VirtualBox VM to a Qubes HVM using this method.

And for the record, the copy/paste issue is not by any means whatsoever restricted to freebsd.

It really feels like u are just saying ‘user error’; rather than attempting to help. for all of your replies. tbh im not sure i even had freebsd working for along enough to neeed to copy paste from it even a single time.

so … thanks for replying i suppose. but id more be appreciative if ud attempted to help me with the questions id asked rather than attempted to undermine my reasons for asking them in the first place.

edited to conform with forum protocols

edited to conform with forum protocols

No. You’re assuming that there is some kind of overarching design behind “the guides” that could achieve this, when in reality, they are written mostly piecemeal by independent community members. What you’re describing would require a level of coordination among disparate authors and editors that simply does not exist. Things are much more decentralized than you’re imagining.

Have you tried simply waiting a bit and trying again? Besides that, Fedora template updates just work out of the box with no tinkering required. That has been my experience for around a decade of Qubes usage, and it matches the vast majority of experiences from what I’ve observed from other users. Such problems seem to be rare and usually due to some kind of tinkering that broke things.

I think you are making things harder for yourself than they need to be.

1 Like

The answer to the curl error. Should anyone similarly get stuck. Is that I was arresting to download the updates directly to the template rather than via the update qube.

I also found a subsequent error which may have been causing a number of errors/ the quixk death of a number of inatalla: one of my installations was in mbtle and the other in gpt. But I only realised whenimpur the two drives together in.a logical array.

Since then.ive been having real difficulty installing anything at all given I managed to delete the uefi drovers from both disks. Spent many hours dicking around in the bios since then. Finally to my chagrin I managed to reinstall w10. Ent a little earlier on a secondary sd . But keep on getting to a perpetual grey screen just before the date/time part of the qubrs install. Have tried cleaning the drive I wish to use with erase in diskpart.has enough for tonight tho gonna go catch a few zzzs before work