Corrupted backup

Hi there.
2 days ago I backed up my qube.
Size 93GB.
Qubes said backup was done sucessfully.
I didn’t verify because I trusted you. Fail.

Now I can’t restore.
I get message: unexpected end of archive.

I tried emergency restore v4.

I manage to get private.img file.

But no mather how many tutorials I followed I can not mount this image.

Tried with mount, lomount, kpartx.

Who wants to help me?
Is there any other way to mount this image or extract files out?

My primary disk is 256gb with more than 200gb free space.
Second disk is 2TB. 100%free.
64gb ram i7.
Qubes 4.1

I think backup file should be around 110Gb.
I have 93gb.
There is now 17gb lost.
I can live with that.

How to extract now the rest?

Correct solution will be rewarded with cryptos.


I cant add up your numbers. Was the backup made on the same system, or
on some other Qubes system - what version was running on that system?
What filesystem were you running on the source?

It would be helpful if you said what errors you saw when you tried to do
something with the private.img file. “Nothing” is unhelpful when you
haven’t given any detail on what you were doing.

1 Like

Hi @unman

I made a backup on my Laptop, Qubes 4.1
After I backed up everything I made a fresh install.
I installed again 4.1 on same machine.
Same settings, same user, everything was selected same as before.
Filesystem is ext4.

I managed to extract private.img following backup-emergency-restore-v4.

On the 6th step when I wanted to do:

find vm1 -name 'private.img.*.enc' | sort -V | while read f_enc; do \
    f_dec=${f_enc%.enc}; \
    echo "$backup_id!$f_dec!$backup_pass" | scrypt dec -P $f_enc || break; \
    done | tar -xv

I didn’t compress my backup so I left out: " | gzip -d "

I get error: Unexpected end of file

On Step 7 I can not do this:

sudo mount -o loop private.img /mnt/img/

I get error:

mount: wrong fs type, bad option, bad superblock,
       missing codepage or helper program, or other error

With lomount I managed to get my private.img in Qubes Devices and I managed to mount it to some qube.
But when I try to open this disk in Thunar, I just can’t.
Nothing happens.

I tried also to guestfist in my private.img

Now I can’t mount it, I do not know how to extract it.

I am very sad.

my last post was removed from Akismet bot

The final step of creating a backup states:

  1. Test restore your backup. Follow the restore procedure, selecting Verify backup integrity, do not restore the data. This step is optional but strongly recommended. A backup is useless if you can’t restore your data from it, and you can’t be sure that your backup is good until you try to restore.

To save others from a similar fate, I think it would be very helpful to implement an automatic verification option in the backup interface, if any community devs reading this are willing to help:

Does anyone know any forensic app for extracting data out of corrupted private.img file?
Something that can dig inside and find files?


You could copy private.img to a no-network VM and run testdisk on it, from the package of the same name. It can recover data from truncated ext4 images (“Non partitioned media”).

tnx @rustybird

already solved my problem with your tool and photorec

so many corrupted family photos, but I managed to save 63 GB of data.

I am closing this.