Copying from dom0

Hi is there a trick to copying a screenshot from dom0 to a dispVM to post it here? I follow the guide and it does not work. I have tried around a hundred times. I also can not move it to any other VM.

I was able to get it to actually create the qubes incoming folder once but it was empty. I am also unable unable to copy text in dom0 so I can not even post the error from the dom0 terminal so I will type it out instead.

[user@dom0 ~]$ sudo qvm-move-to-vm personal screenshot_2023-01-13_18-04-16.png
stat Screenshot_2023-01-13_18-04-16.png
sh: zenity: command not found
EOF <-EOF in red letters

I also have no application in dom0 that can deal with text documents from what I can find. I wanted to try to past text from the terminal from dom0 to the dom0 files to see if I could copy from there and global clipboard it to here but when I create a plain text file there does not appear to be any app that can open a plain text file for me to paste into or type in.

My qubes install is basically stock, all I have done is app a few packages to my personal vm. I installed qubes fresh this morning to start fresh as I had done a lot of stuff trying to fix graphics issues that didnt work and wanted a fresh install.

Am I missing something?

Thanks in advance!

There’s no need for privileges. Second, path is not good. So

[user@dom0 ~]$ qvm-move-to-vm personal ./screenshot_2023-01-13_18-04-16.png

Of course, if your screenhot is in /home/user folder. If it’s somewhere else (for example Pictures folder), just replace “./” with full path.

Third:

Copy text to clipboard then use "Copy dom0 clipboard" widget, then CTRL+SHIT+v to destination qube then CTRL+v into destination qube

1 Like

I have followed the global clipboard instructions and it does not work. It works fine as described from vm to vm but will not copy from dom0

Hmm Ill have to look for what copy dom0 clipboard widget it. Ive been trying the ctrl+c-ctrl+alt-c-ctrl-alt-v-ctrl+v way like for other qubes…

Also I just tried as you posted for qvm-move-to-vm and I got the same error. I guess I should have explained further that in the hundred or so times I tried I tried every possible syntax I could conceive of. I had not tried the ./ like you posted but just did to no avail.

You did help a lot though thank you. I was not capitalizing the p in Pictures. It just worked with
/home/user/Pictures/screenshot_2023-01-13_18-04-16.png

Thanks a lot, I can now try to get some help with the graphical issue I am having :wink:

You’re welcome. Good you resolved it.

1 Like