Copy to Windows standalone without QWT or Xen PV drivers

Hello. I need to copy files to my Windows 7 standalone.
As far as I know, Qubes Windows Tools (QWT) may be used for that, as well as Xen PV drivers. However, installing these seems to increase risk for dom0.

I saw this: How to mount LVM images | Qubes OS
And I hope that someone can tell me how do I use this way instead, to copy files to my Windows 7 standalone.

What I don’t understand is this part:

Example: /dev/qubes_dom0/vm-debian-9-tmp-root
[user@dom0]$ dev=$(basename $(readlink /dev/YOUR_LVM_VG/YOUR_LVM_IMAGE))
[user@dom0]$ qubesdb-write /qubes-block-devices/$dev/desc "YOUR_LVM_IMAGE"

I can’t know how do I replace YOUR_LVM_VG or YOUR_LVM_IMAGE. Tried to replace YOUR_LVM_VG with one in the example: qubes_dom0, but it doesn’t exist in /dev.

And most importantly, is this way, in the first place, better for security than the QWT or Xen drivers way? Because you don’t install additional software that are quite regarding Xen stuff that their bugs are fatal?

Did you install Qubes OS with default partitioning? It should use LVM with qubes_dom0 volume group name by default.
You can use lvs command to find out your VG and LV names.

I’ve done the Qubes installation on an SSD that’s completely unallocated and while I don’t have any other drives. I chose the ‘automatic’ option instead of the ‘custom’ or ‘advanced gui’. If that what you mean.

Executing sudo lvs in dom0 prints nothing.


What should I do? Do I have to reinstall Qubes?

What do you have in /etc/fstab file in dom0?
You can remove UUIDs from there before posting here.

The content of /etc/fstab:

#
# /etc/fstab
# Created by anaconda on Sat Apr 27 14:31:25 2024
#
# Accessible filesystems, by reference, are maintained under '/dev/disk/'.
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info.
#
# After editing this file, run 'systemctl daemon-reload' to update systemd
# units generated from this file.
#
/dev/mapper/luks-xxxxxxxx-xxxx-xxxx-xxxxxxxxxxxx /                       ext4    defaults,x-systemd.device-timeout=0,discard 1 1
UUID=yyyyyyyy-yyyy-yyyy-yyyy-yyyyyyyyyyyy /boot                   ext4    defaults,discard 1 2
UUID=ZZZZ-ZZZZ          /boot/efi               vfat    umask=0077,shortname=winnt,discard 0 2

*Hand wrote them, because I can’t copy from dom0.

Your Qubes OS was installed without LVM with root on bare ext4 for some reason.
There is also no swap that should be created by default.
By default with automatic partitioning it should create LVM and your fstab would look like this:

I don’t know why LVM wasn’t created.
I’m not sure how VM disk images are stored in case of bare ext4, but you can check if you have them in this directory:

/var/lib/qubes/appvms/VMNAME/root.img

Then you can make it available for attaching like this: