Copy and paste - I didn't select anything!?

I have been having problems with text that I haven’t selected being pasted exactly where I need it. What I mean is, when working between two documents or webpages; (filling in one and referring to another); I’d read/refer to the webpage/doc 1 without copying and when I go back to the webpage/doc 2 and start typing the information I need (but didn’t copy) is pasted into the correct part of the document or web page even though I didn’t copy the text. This sounds and feels like someone is in my machine somehow and is toying with me (which wouldn’t be the first time!). I’m aware Gnome desktop has unique copy and paste functionality (you just have to select text and hit paste when ready), but knowing what you need and where to paste without me copying or pasting is creepy!! Does what I’m saying sound possible i.e. someone can copy text while and paste where needed while I’m using the computer!? Help please!

Can you please describe what here is Qubes specific. specifically?

Are you talking about two things on the same VM or two different VMs?

Are you asking which Qube? if so it started in the Work Qube so I created a new one and it happened again in the new work Qube!!

The same VMs

Enmus was thinking you’re not having an issue with Qubes, specifically (“Qubes specific”) but rather with something else. And now that you’ve told me both windows are in the same VM, I tend to think he has a point; your issue is with something that is not part of Qubes per se.

“Qubes-specific” is not the same as “specific Qube”

What are we talking about here; Rootkit/Malware of some sort?

I don’t know Qubes (or Linux) well enough to say whether this is a Qubes specific problem. However I only use Qubes on this laptop, I run updates via the GUI only. So if it’s not a Qubes problem it’s a hardware problem?

SlimGym maybe that’s just an autofill feature?

If you can: describe a harmless example that doesn’t reveal anything about you but could be reproduced by others.

Thank you @Sven; so I’m entering an expiry date from my credit card which is held in my password manager - I must stress i haven’t copied the date I’ve gone to memorize it. I take note of the date and I go to the web page and in the middle of typing the date the date is pasted into the field!?


Actually, I’m kidding myself; I know there is something sinister going on because this has happened before when using tails OS earlier this year, so I bought a new laptop (Lenovo T430) I’m using now. I bought the laptop in August and have been using it extensively for the last 4 months; the copy and paste issue has only started in the last 2 weeks with nothing like that happening prior. Rather than go out and buy a new laptop I’m going to list things that may have compromised my laptop or installation of Qubes so I can learn more about my actions. I bought the laptop pee-installed with Qubes to be used along side a Nitrokey.

I upgraded from 8GB RAM to 16GB ( I said I would list everything)
I recently formatted a USB harddrive on another machine as it may have been compromised - I’m sure I used a disposable VM but I did restore a backup VM from the Drive!
For the last 2 weeks at least, every time I login there has been a Fedora 36 update to run - I haven’t logged in everyday but I’d say 8 of the last 14 days I’ve logged in and had to run a Fedora 36 update. i find this weird especially with Fedora 37 on the Horizon.
I recently download snapd - not sure if this could be a way in although it was on a different VM.
I had an issue with my machine not booting up as I ran a back-up that used all the space up so wouldn’t boot up, so I created a USB boot disk and went in mounted the drive using the shell and deleted the back up file in question.

Barring that, then the machine was compromised from the start - which is possible as the only reason I’m using Qubes is because I am being harassed/bullied/cancelled. Feedback/ideas of any kind gratefully received.


Sorry, didn’t mean to scare everyone!! Any recommendations or ideas!?


Try grabbing a libreboot compatible motherboard. “Intel management engine” and “amd psp” is a special “computer within your computer” that has access to and controls everything you do on it. see: Libreboot. How do you think snowden was able to reach into people’s webcams with only a personal email? My guess is that snowden didn’t leak the bit of info on “Intel management engine” and “amd psp” because it would disrupt the world’s computing and send technology back by a decade until these rootkits were removed. Your router is swiss-cheese in terms of security, try grabbing a libreCMC router that is just a wee bit more secure than your typical router. Sorry you are going through this, it’s a long road to secure just a tiny bit of freedom.

This just seems like your browser is automatically picking up shipping/payment information and storing it until it recognizes similar fields. As Sven said, this is just the browser autofill default behavior for some browsers.


1 Like

It really is a long road!! Thanks for your response, I will certainly look into it.

I’ll look into this as well, thank you @brendanhoar, @Sven and @SteveC