Convert back oracle linux 8 to a template or appvm like

Hi all,
I’ve installed a centos-8 template, upgraded it (as reported in: ), then cloned to a new one and converted to oracle linux 8, with migration script ( ).

Now I’d like to revert it to a “standard” appvm, so I’d like to re-enable salt automations (for example update it from dom0, etc.);
I’ve yet looked in qubes-* packages installed in new oel8 and (of course), they are less than original centos8 from which I’ve started;

so can You please suggest me how to do it?
Thanks a lot,

I believe I should be in charge of this since:

  • I wrote the migration guide
  • I have experience with migrating several Enterprise Linux releases

That said, I’ve been reading this message a few times and still don’t understand, what’s there to accomplish. Also:

  • what’s a standard appvm?
  • what are less than original packages in OEL8?

If it’s just about instancing and AppVM from a Template, then you can do it within Qube Manager - just click the New qube option and create one based on the OEL8 Template.

my bad…
I mean I’d like to use the new converted oel8 VM as the old centos8 one, with qubes integration features.

During migration I’ve had to disable qubes.repo, and from console I’ve seen some (qubes-)pkgs have been overrided or removed by migration script.

Infact if I do a rpm -qa | grep -i qubes on both Centos8 VM and on OEL8 one, as reported, I can see less qubes-pkgs installed on latest one.

Of course I think its not a good idea to try to reinstall them by hand, for avoiding to install not needed pkgs, or worse break oel8 repo image.

My goal is to update it again by qubes update (attached log of what happens if I run it now), access qubes daemon logs from qube manager and not simply see journalctl one and so on…

I’ve started from a centos template for avoiding to use it as a standalone VM.
I hope is clearer now.
Thanks a lot,

qubes_update.log (5.4 KB)

OK, now things are more clear!
Well, what can I say: I have the same result on my EuroLinux 8 template. In fact, when I want to update it, I don’t use Qubes Update at all, but just open the template, update it from itself and close.
It’s not as convenient as the centralized update manager so if you manage to find out the solution for that, I’ll appreciate it.

of course if I get chance to do it, I’ll share solution here, but just for my understanding:

  • noone know if exist a QWT, maybe exist a procedure for linux too?

Or a salt state?
[of course I’ll try it at my risk!]
Thanks anyway,

I’ve reinstalled in oel8 all pkgs I can see in centos8, but nothing changed.
I think reason is the (probably?) missing pkg: Python38-yum-plugins-qubes-hooks-4.1.17-1
or something like it…
What do You think?