Control cpufreq from dom0?

I looked at xen documentation and found this Xen power management - Xen “cpufreq=dom0-kernel” xen boot option. But when i try it i still can’t control the cpufrequency from dom0 and cpupower still doesn’t work despite the documentation saying it gives dom0 control over cpufreq. Why isn’t it working when the documentation says it gives dom0 cpufreq control and how do i fix it? even with smt on it still doesn’t work and can’t control it from cpupower


“It seems that starting with Xen 4.9 it hides CPUID leaf 0x06 from dom0.” but from the patch notes of qubes “Xen upgraded to version 4.14” so xen should be version 4.14 instead of 4.9 in qubes?

1 Like

This patch applies to all Xen versions starting with Xen 4.9. Xen 4.14 is newer than Xen 4.9 so it’s applied for it as well.

1 Like

is it possible to downgrade xen or to stop hiding the CPUID leaf?

Not possible if you’re an ordinary user.

the power management of xenpm is too bad and it prevents me from using qubes and i can’t control it from dom0 too because of cpu leaf. What about downloading an older qubes iso? my threat model isn’t high but i can’t find older versions of qubes and there is only the new stable and testing release in qubes website

You can try Qubes OS 4.0.4 but it’s not supported anymore:

tried it but cpupower still doesn’t work. it still can’t find the frequency info and change it but the coretemp module was loaded

why isn’t it working in the older version too if cpu leaf isn’t hidden?

I don’t know, maybe there are more limitations apart from hiding CPU leaf that don’t allow cpufreq usage in dom0.
It’s better to ask this in Xen support mailing list or matrix channel instead of on this forum.