Connected USB-Keyboard changes the language layout


if I connect a usb keyboard (to my laptop), it changes the language layout from german to english. After that I must restart the VM, to get the old (german) layout.

Where can I permanently set the german layout for the connected keyboards?

#Edit: is the problem so special or too common to be answered? :slight_smile:

Best regards

Hi @qun,

not a solution but an idea.

After connecting the USB keyboard, check the keyboard setting in the XFCE settings.
Open the Applications menu (most left Q in the task bar), choose System Tools > Keyboard .
In the Keyboard opened window, select the Layout tab, then check the keyboard layout and the keyboard model. May be you can configure the good layout for your new USB keyboard and keep this setting…

Other ideas:

  • read the Archlinux wiki for Xmodmap
  • check the dom0 xorg logs
  • check the VM logs (what is your VM type ? AppVM/StandaloneVM/…)
  • Qube Manager allows to set keyboard layout by Qube, play with it
  • I don’t find the qube keyboard layout with qvm-prefs <vm>, search with other CLI qvm- commands
1 Like

ok, its crazy simple :smiley:
just right click on the VM (standalone in my case) and choose “set keyboard layout”.
Sometimes the things seem to be more complicated as they are :smiley:

Thanks for the idea with the Qube Manager!

1 Like