Configuring qubes for multiple screens 1080p x 5

Problem- i have mouse cursor lag when switching between screens

how are the screens connected?
2 through z690 12700k
3 through gt 730 gddr5

What have i tried before this?
tried the commands on qubes- video ram configuration page

tried alt shift f12 which turns off compositor
it helps a little but does not solve the issue
this issue was not occuring before i created sys usb qube,
i have a usb keyboard so sys usb was created manually using qubes doc

What solution am i expecting??
first of all an explanation of what the commands at the qubes video ram configuration page actually do??
how to reverse those commands?
do they change the videoram allotted to a vm or to dom0???

Do i need those on my system.
I have 5x 1080p screens

running kde
any help is greatly appreaciated

talking about commands on this page

The problems you are facing sound like problems with the driver, not graphics RAM imo. I am running multihead with 3 or 4 screens without touching the RAM, but only FHD.

First try to find out what video driver is used, for example with sudo glxinfo -B in dom0.

The important lines are those:

direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: X.Org (0x1002)
    Device: AMD RENOIR (DRM 3.40.0, 5.10.104-3.fc32.qubes.x86_64, LLVM 10.0.1) (0x1638)
    Version: 20.2.3
    Accelerated: yes

(those are mine, yours will of course vary)

Not sure what you mean, i think you expect it to work flawlessly :slight_smile:

So the first command increases the minimum video RAM.

You should be able to reset the values to default with qvm-features dom0 gui-videoram-min --default (i guess, never tried)

Sorry, i am not too deep into tha, so i am just guessing here. From my understanding, this is the memory allocated in dom0 for every running qube.

So just to make this clear: The only thing you have problems with is “mouse lag”? What is mouse lag for your? Is it a low cursor reffresh rate, or input lag (time between physically moving the mouse to the cursor moving)?

Another thing that might hint to a driver issue is screen tearing when moving windows.

my output of glxinfo -B is
temp.yaml (1.0 KB)

name of display: :0
display: :0 screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
Vendor: nouveau (0x10de)
Device: NV106 (0x1287)
Version: 20.2.3
Accelerated: yes
Video memory: 1968MB
Unified memory: no
Preferred profile: core (0x1)
Max core profile version: 4.3
Max compat profile version: 4.3
Max GLES1 profile version: 1.1
Max GLES[23] profile version: 3.2
OpenGL vendor string: nouveau
OpenGL renderer string: NV106
OpenGL core profile version string: 4.3 (Core Profile) Mesa 20.2.3
OpenGL core profile shading language version string: 4.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.3 (Compatibility Profile) Mesa 20.2.3
OpenGL shading language version string: 4.30
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 20.2.3
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20

i have the option of choosing which gpu is initialised first in my bios and since 3 displays are connected to the gt730, i choose the gt 730, another reason of doing this was there was a lot of screen tearing when it was initializing my igpu which is the one with 12700k first.

so it is using nouveau drivers.
is there a way that i can switch to intel drivers and stiil have all display’s working

What i mean by mouse lagging is, when i move it between displays, it just stops on entering a display with diffferent refresh rate.
I have 5 displays 3 are running at 60 hz
one is at 166hz and one at 144

mouse would just stop for some miliseconds, noticeable and irritating, when it enters the 144hz display from a 60hz display/

Something i can do ???

So your driver looks good. It is using the open source driver for nvidia.

I heard that those don’t are that good in some cases, so you could try to use the proprietary ones from nvidia, maybe this will solve the problem.

Unfortunately i do not have a system with multiple gpus to test this, nor do i have any experience in this.

This seems to be your problem. As i have only 60Hz monitors i cannot help you there either :/.

However i would suspect that this might be a problem not related to qubes specifically, but with linux in general so maybe you are able to find other information on the internet.

What you could try is to set all monitors to 60Hz and see if the problem persists.

1 Like

how are you plugging in 3-4 screens???
you do not have a dedicated gpu??
i have only one gt730 in addition to intel igpu

are there some special steps you followed to make >3 screens work simultaneously?

On my desktop i plug all of them into my dedicated GPU.

I do, but i do not have a system with a dedicated and integrated gpu.

No, i just plug them in and it works

solved this
sys-usb was the issue, i was using the one i manually created because i was using usb keyboard and mouse

Removd sys-usb and the freezes between mouse movement from one screen to another stopped.