Compatibility Issues: Intel Evo and Qubes OS

Hey everyone,

I’m experiencing compatibility issues between Intel Evo and Qubes OS. Any advice or solutions?

I recently tried installing Qubes OS on an Intel Evo-certified laptop but faced several problems:

UEFI/Secure Boot: Qubes OS requires disabling Secure Boot, which is enabled by default in most Intel Evo laptops. Disabling it may pose security concerns.

Drivers and Hardware Support: Some Intel Evo laptops lack proper drivers or support for Qubes OS, causing issues with graphics, Wi-Fi, touchpad, etc.

Power Management: Intel Evo laptops have OS-specific power management features, which may not fully support Qubes OS, resulting in suboptimal power management and reduced battery life.

Function Key Assignments: On some Intel Evo laptops, pre-assigned function keys may conflict with Qubes OS functions, making it difficult to access necessary features.

Any tips or workarounds would be greatly appreciated. Let’s collaborate and find solutions!


Please apologize if this would sound harsh, but you don’t buy hardware you like and then try to install Qubes on it. It’s exactly the opposite. You decide you’d like to use Qubes first and then try to identify the hardware for it. That is what HCL list and user experiences here are for.

Have you tried installing 4.2.0-rc1?

let see i will tried it

On 4.1, did you try a 6.3 kernel?