Community template install impossible

I tried both methods listed in this guide. Unfortunately, none of them worked. I copied the RPM files to dom0. When I try to verify the templates I always get a negative output. I used the unman key 4B1F … C2EF, and downloaded the files several times from the official repo.

rpm -K template_name.rpm
template_name.rpm: checksum SIGANTURE NOT OK

The second method is similar.

sudo nano /etc/qubes/repo-templates/3isec-templates.repo
qvm-template list
[Qrexec] ERROR: Failed to download metadata for repo ‘3isec-templates’: cannot download repomd.xml: cannot download repodata/repomd.XML: All mirrors were tried ERROR qrexec call ‘qubes.TemplateSearch’ failed.

Does anyone know whats the problem? @unman

You have added sudo to the qvm-run command.
This wont work because sudo will not operate through redirection(>)
My guess is that you are trying to copy the template to somewhere owned
by root. The sudo command runs the qvm-run but the output write is
performed by user.
There are ways around this:
sudo su - to get a proper root shell
Or qvm-run -p QUBE 'cat path_to_template' | sudo tee template name > /dev/null

I would just copy the template to somewhere owned by user.

I cant replicate your error in setting up the repository.
What version of Qubes are you testing on?

I never presume to speak for the Qubes team.
When I comment in the Forum I speak for myself.