Common denominator with Qubes 4.1 problems

I just installed Qubes 4.1 Beta. I used the default options for install. I had an issue in that that the WiFi in the laptop was not functional, or listed.

Oh wait, I needed to set . . .

Got tired of looking, I actually put a USB Dongle in. Qubes would not see that one either. So I rebooted.

on restart Computer did something it did not do the first time. It asked for me to enter PW for Disk Encryption. Then PW for user account.

Before it just asked me for PW for User Account.

Seemed to start into desktop both times.

As I see a lot of individuals with problems with Qubes 4.1, I feel that a reboot or two might allow OS resolve the issues they are having.

I dunno. Might need for one of the more knowledgeable Qubes to list cases when rebooting is needed. We already have documentation on how to repair –

Well it is strange a beta downgrades some critical function instead of upgrade. I’ve done 4 different installs from an iso and had no network connectivity. I also rebooted a few times. I had no network so I couldn’t do anything else, like trying different kernels, so I went back to 4.04.

I also tried the in place upgrade that failed. About OS showed I was on 4.1 but the core versions showed 4.04 and so was the UI.

"Well it is strange a beta downgrades some critical function instead of upgrade. I’ve done 4 different installs from an iso and had no network connectivity. I also rebooted a few times. I had no network so I couldn’t do anything else, like trying different kernels, so I went back to 4.04.

I also tried the in place upgrade that failed. About OS showed I was on 4.1 but the core versions showed 4.04 and so was the UI."

Good you added more detail. Perhaps I should have added more detail myself.

I was using an 2016 Alienware 17 with Skylake I7, 16 GB RAM, Installed onto an M2. To which I first tried to use the two red Terminal Icons on the top right to activate WiFi. I tried to start Firefox (Fedora) in Disposable App, no joy, but I did change the Search Engine in the Template Fedora from Google, to Duckduckgo. I tried to start Sys-Net, no joy, there is a Network something that was greyed out, no entries taken. I put in a Wireless Dongle, a Real Tech (RTL) which I know works with several versions of Linux without installing software for it. Started Sys-USB. Sys-Firewall. No joy.

I did a Restart, with the Dongle left in. Then it did what it had not done the first start, asked for PW for the Drive. Came up, Started Fedora DappVM, and Using the two red terminal Icons, showed possible Wireless connections. Picked my phone Hotspot, entered PW for Hotspot. Wireless worked, WiFi seems reasonably fast. Takes 20 seconds to start an AppVM. I have not used this install of Qubes a lot, but Qubes uses WiFi.

As I think back, I had installed a previous version of Qubes 4.1 last week from the Friday download, not the Beta. That version of Qubes worked very slowly. I did get it with WiFi connected. Took a long time to start a new web page. Seemed to hang if I tried to switch to another TAB in same DispVM -Fedora Firefox browser.

When I booted that version several times, and was never asked for PW for Drive. Just the PW for the account, which I thought must be a new feature of 4.1.

Joe, Did your install ask for PW for Disk Encryption? Then PW for Account login?

On the initial install you enter your disk pw during the setup and then you enter the account pw to login. On reboots you have to enter the disk pw or else you can’t access the drive to login to the OS. I don’t understand how you were able to access the drive without the pw.

Everything is worked for my laptop and nothing changed from 4.0 to 4.1 except kernel / driver required for my laptop.

Instead of assumption, it’s best for you to ask directly what do you want.

I’ll try to answer your doubts :

Mind telling me what’s your wifi card ?

I’ve never think like this again after hundred of reinstall and operating qubes os; bios, uefi, discrate gpu card / hybrid mode. 3 things of this is matter for succeed installation or even it succeed there’s something causing glitch on dekstop, uefi + discrete gpu card only is work best for my laptop (modern laptop), uefi + hybrid mode (igpu + discrete) cause glitch on luks decryption and after user login, using legacy is much worse.

If in installation you tick / use encryption. It’ll 100% asked, if you not asked then it mean you don’t encrypt the disk.

Good you came along to correct me, I am usually wrong.

I recall it is Qualcomm Atheros. I don’t have Alienware with me. I will look later.

Need to reboot. In a time of the year when Sunspots are off the chart. When Linux Torvalds has suggested that computers need Error Correcting RAM, and I know I do not have. Rebooting long been the first attempt to get a problem to clear. In 2009 Apple Genius, who got his advice from more knowledgeable Apple tech employees, said to reboot every day. Rebooting is not standard to a lot of Linux Users, and for good reason, Linux is quite stable and written to go for days without re-booting.

Still, Rebooting is, for those of use who make frequent errors, the first way to clear a minor issue, rather than trying to find where else it might of gone wonkers. In this case it worked. I see issues with suspend, graphics, and such that make little sense. Rebooting I don’t think will cause damage to computer or install.

This weekend, I will try to figure out where I went wrong. If there is any way to make a mistake, I will.

It’s a beta. Users are victims. I still see 4.0 as a beta.

yea just ask if you already check it.

The issue is linux has been blamed for kernel error. but torvald said it’s hardware issue that lead to non ecc ram.

The problem is users have low knowledge about linux and doesn’t have time to learn, before i use qubes. i use debian sid as main os for long time, altought i’ve faced some critical update that lead to broken my system. i’ve never facing it in qubes.

Just saying beta users are jokingly known as victims. But I’d have to disagree conceptually and from a sales perspective, because products provides solutions for people. People feel deterred and frustrated when it works the other way around. Also I’m aware this isn’t a company with resources and funds at work. It’s easy to forget all that.

I wanted to do install over again, and try to see what I might have done that was unusual.
I was looking at downloading the latest Friday 4.1, then while I was looking at ISO’s, I realized that the 4.1 Beta I had tried to install was from July 11, 2021, and we are in September on 4.1 ISO’s. I used 9-24-2021 download.

I like the ISO I downloaded had on its first initial splash screen has an ISO number related to date. Thanks to Developers.

Verification of ISO, Perhaps some place in documentation. Warning that if we had been tricked into a fraudulent download of Qubes, that Verification would seem to work.

This whole problem seemed moot. I should download and install the latest Friday 4.1, and install that, see what errors occurred.

I set three passwords;

  1. For disk.
  2. For Root.
  3. For account.

All different. I say that because it was not obvious if the installer would allow- install to run - without -Root having a Password- .

At some point, I had error message,

Dom 0 Qubes OS Setup
Executing qubes configuration

and a second box with:

at the top [Dom0] Error

Qubes initial configuration failed. Login to system and check /var/log/salt/-
minion for details. You can retry configuration by calling ‘sudo qubesctl --all
state.highstate’ in dom0 (you will get detailed state there).

with OK below it.

When I got to restart, I did.

It was then I wondered if I should have already removed the install USB.
It came up with the first part of Install, asking about languages.
went through that, when I got to the point where it was going to re-partition, I thought I had gone far enough.

I pressed down on the power button, and realized that perhaps in a previous install I had put the computer in suspension, which is why it did not ask for disk Password, but asked for Account Password.

I realized this particular Alienware, had not just a graphics card, had what they call a Graphics -Amplifier, which is an extra charge item bolted onto the back of the laptop. Reason I mention this is because when Qubes is trying to do an initial install, this kind of thing might take up more time to install and something gets time limited out.

Notable is that when I put Qubes 4.0.4 on this computer, the screen appearance was not quite the appearance that Windows gave. Since the Windows 10 screen color and depth were so great. I felt I would keep this computer on Windows to watch movies.

In Qubes 4.1, looks like the screen appearance is excellent. Congratulations to Developers.

I pressed power button log enough to make sure it turned off, 'No Suspend."

Powering up I am asked for -Disk Password- then it shows account name, and asks for -Account Password-

I start -sys-network to get two little red terminal Icons, which show available WiFi connections. At this point using the Laptop internal WiFi.

Starting Disposable VM of Fedora -Firefox, takes about 19 seconds.

I did not spend a lot of time using Qubes. I have other computer projects to mess up. Thanks for replies. I hope I am clear with how I created mistakes in using Qubes.

Congratulations to Developers.