Clockception issue

I know it’s a weird way to put it but I can’t think of another.

Okay, so when I type in the date command into dom0, I get the correct time zone. When I type timedatectl status into dom0, same thing. When I type them into personal or any other qube, no issues.

BUT when I open Thunderbird, it seems my time zone is set to Berlin. This computer came from that time zone, so no surprise there, but any attempt to change the time zone to the correct one only changes the “surface” clock, not whatever is making Thunderbird think I live in Germany. What’s going on and how do I fix it?

So timedatectl executed in the qube that runs thunderbird shows the correct time and timezone?


Did you check privacy.resistFingerprinting?

If it’s not that, can you press Ctrl+Shift+J in Thunderbird to open the JS error console? Then type Date() and hit return. Does it show what you expect?

Is your TZ environment variable set? What is it’s value?

resistfingerprinting is set to false, the Date command shows the correct TZ, and I don’t know anything about the third thing.

I should point out that the timestamps on my emails is correct, it is the calendar that seems to be the problem.


So is calendar.timezone.local set correctly?

Fixed that. Hopefully the problem is solved, but would you mind keeping this open for 36 hours just in case? I’ve had similar issues before.

Actually, solved threads are not closed on this forum, exactly because someone could have the same issue for different reason, or to add something later.

1 Like