Charles Proxy and their no longer works


I’ve been using CharlesProxy for a while to proxy traffic from the app I’m working on. It is been in App qube based on Fedora 36 template. It worked pretty much fine for some time, and just recently I noticed a change while I did not update Charles nor I did not changed its config, but I updated the Qube template a couple of times.

Their feature stopped working. This is what charles provides if you want to proxy all traffic to localhost. If you use wherever you need localhost, then Charles will auto-magically proxy it and will forward traffic to localhost (more: Localhost traffic doesn't appear in Charles • Charles Web Debugging Proxy)

I used this feature last time about 3 weeks ago - it worked fine. Today I run it, and can’t make it working.
Any ideas what has changed over the last couple of weeks in Qubes that could affect that? Or maybe any hints where should I dig in?
I tried to reach out the author of Charles but its email seems to be out-of-date.


curl --proxy socks5://

What I get now is
Could not resolve host:
while I expect to get
Success or Connection refused if server is down.

Any advice much appreciated.