Changing time / timezone

What’s the best way of changing time / timezone in Dom0?

I have tried sudo timedatectl set-timezone 'Asia/Beirut' and sudo timedatectl set-timezone 'America/Aruba' and while timedatectl displays the correct local time according to my selection, the clock does not change. I’ve tried setting time directly with sudo timedatectl set-time "2020-11-08 20:30:00" but again, no change.

Currently I have selected ‘no’ for Network time on, RTC synchronized, and RTC in local TZ. Do I need to enable any of these options? Again, I’ve tried but it doesn’t seem to make any difference. Perhaps I haven’t hit on the right combination yet?

timedatectl set-time 20:30:00

I answered just because you opened an OLD Wound. I had GPSD with a GPS clock set up in Qubes. It took me about 3 month to get it working correctly and 3 month later some mother-lover-update…

Probably you should synchronize auto with system time and check with some other program (i2p will notify you of clock problems)…

Did you try relogging or rebooting afterward?

Hi @adw. Yes, done all that.