Can't use keyboard or mouse: not enough disk space?

In my current setup, the sys-usb vm is responsible for keeping all USB devices including keyboard, mouse and etc…

After creating the test-vm and downloading a relatively large file, I have exceeded the disk threshold limit above 90 % and now the sys-usb vm won’t start during the regular boot process.

This is preventing me to use the keyboard and/or mouse once the OS is fully loaded

I’ve tried to free some space on the disk by using the live - bootable Qubes OS ISO - USB drive.

These are the steps I’ve taken:

 $ cryptsetup open /dev/<device> luks-qubes
 $ mount /dev/mapper/qubes_dom0-vm--temp--private /mnt
 $ cd /mnt/user/home/Downloads
 $ rm large_file.iso # --> ~12GB which resulted for the disk quota to be exceded.
 $ umount /mnt
 $ vgchange -a n
 $ cryptsetup close luks-qubes


System reboot: ok
System boot: ok
sys-usb vm won’t start due to the insufficient space on disk.
No keybord/mouse

It seems that large file deletion did not help at all. Does anyone have any idea on how to free up disk space?

Boot with disabled qubes autostart so your keyboard and mouse will work in dom0:

Try to start/restart to VM with removed large file a few times.
Qubes OS is keeping one revision for each volume so the large file is still present in the old volume revision.
You can also run fstrim in your qube and in dom0:


Thank you! This solution works perfectly.