Cant update whonix 16

I get this error when I try to update whonix-ws-16 with the qubes os GUI update tool:

Updating whonix-gw-16

Error on updating whonix-gw-16: Command '['sudo', 'qubesctl', '--skip-dom0', '--targets=whonix-gw-16', '--show-output', 'state-sls', 'update-qubes-wm']' returned non-zero exit status 20.
  ID: update
  Function: pkg.uptodate
  Result: False
  Comment E: Release file for tor+ is not valid yet (invalid for another 9h 34min 0s). Updates for this repository will not be applied.

The comment in the output has multiple lines saying

Release file for tor+[some url] is not valid yet (invalid for another 9h 34min 0s). Updates for this repository will not be applied.

Idkk how to copy text from dom0 in a secure way so I had to type it by hand. That’s why I left out some information.

I have a similar problem when I try to update whonix-gw-16

The output you copied here states that the package information found online was in the future compared to the time and date of whonix templates where updates were to be applied, so the update attempt failed.

Seems like dom0 time is skewed and template receives that time, being in the past and invalid.

Most probably a result of suspend/resume issues, and definitely the result of clock drift.

Mitigation is to reconnect network, time should sync to dom0 and the proper date and time be propagated on next templatevm start up.

Otherwise you can open a dom0 terminal and type manually, while having sys-net connected to internet:
sudo qvm-sync-clock

This will have sys-net or time qube attempt time sync through NTP protocol over the internet and might lock your screen (screensaver will kick in just as if no interaction happen for that time drift, which would be normal in the circumstances).

Packages fixing a bunch of xmm-xen issues just landed into testing repositories.

I would suggest sticking with above mitigation until the packages are properly tested and landing into stable repositories, to be installed automatically when ready for production environments.

Fixes at play: Suspend and resume stubdomains by DemiMarie · Pull Request #139 · QubesOS/qubes-vmm-xen · GitHub

1 Like

it happened to me too.
start template , open a shell and launch:
sudo apt upgrade
If it’s the same issue of mine, You have to launch:
sudo dpkg --configure -a
to fix pkg status.
then update from qubes tools may me back to work as expected.
Let me know.

I think it worked by closing down the vms and reconnecting to the network. Whonix 16 was updated.

1 Like

Im having problems again. Closing down all vms and reconnecting the network didnt work this time. I get “command not found” when I run qvm-sync-time in dom0.

1 Like


# qvm-sync-clock

1 Like

Thanks, corrected my post. Was qvm-sync-time instead of qvm-sync-clock, sorry for the error.

1 Like