Can't update template due to issue with Brave repo


I installed Brave Browser in my main fedora 38 xfce template (qubes 4.2), which by the way, was difficult to do - I’m quite bad at the technical side of things! It works fine. However, I can’t now update my template. The error says:

Updating fedora-38-xfce

Failed to download metadata for repo ‘brave-browser-rpm-release.s3.brave.com_x86_64_2’: Cannot prepare internal mirrorlist: Cannot resolve path for: “2”

I would assume that the 2 it referenced was the 2 in the code above, but I don’t know how to change that. or reinstall it? I hope not, it was hard to set up brave over and over again for each instance. Can anyone help me solve the issue?


I ran into something similar last night.

It turned out that this was the first time I had ever tried to update Brave without a cacher running, and the script was trying to use the cacher (it was getting the key, etc., with http://HTTPS/// instead of https://).

I was able to solve my problem by checking to see if there’s a cacher, then using the appropriate calls.

I have no idea if this is any part of the reason you are having trouble, but even if not this might help someone else.

Thanks for this info. Related to my issue or not, I’m going to annoyingly ask :
1- what is a cacher (I think it’s something to do with the proxy for installing on to a template…?)
2- should I have one set up?

Well, that reassures me you’re not trying to use the cacher (unless you copied the command from someone who is–if your command has HTTPS (all caps) anywhere in it, it’s wrong)!

The cacher is in fact a proxy as you suggest. When being used template installs go through it (and it’s then attached to sys-firewall and from there to sys-net). The idea is for the cacher to download things, then keep them around. If another request for the same thing comes through from a different template when it installs or updates, the cacher uses its downloaded copy instead of downloading it again.

It’s mainly of benefit to those who have many different templates. It probably doesn’t make much sense for people who leave the default install the way it is (one template for every qube: sys-net, Work, Personal, etc.).

1 Like

Thanks, I won’t trouble myself with a cacher for the moment then. I don’t think the tutorial I followed mentioned one. I’ll have to try to dig out the one I tried that actually managed to instal brave in the first place. I found it so hard to even download.

It’s a pain because of the whole wget-curl thing. You can’t just do it with sudo apt-get (or the fedora equivalent), you have to go through this whole donkey derby of additional steps, and it’s made harder in Qubes. Unfortunately more and more people are choosing the donkey-derby method of distributing their software. (apparently it’s deemed more secure…of course, if you can’t install it, it can’t be malware infecting your system so I suppose they succeeded!)

I just want to BUMP this thread. I don’t know how to resolve the issue, but I currently cannot update my fedora 38 xfce template due to this error:

Updating fedora-38-xfce

Failed to download metadata for repo 'brave-browser-rpm-release.s3.brave.com_x86_64_2': Cannot prepare internal mirrorlist: Cannot resolve path for: "2"

Should I uninstall Brave and reinstall it another way? I just successfully update brave using dnf update brave-browser, so I’m not sure why the template update mechanism has a problem…

What do you have in your repo file?

cat /etc/yum.repos.d/brave*

Maybe try to remove and add it again.


THANKS! This has lead me to solve the issue. I didn’t need to re-add the repo, but within the .repo file was a surplus 2 for some reason. I deleted it and managed to finish the update.

Thanks for passing along your knowledge.