Cant Update Fedora and No Internet since today :(((

So i am a total noob to Linux and Qubes. I Just Managed to get everything to Work and it worked for some days and today i Made a dom0 Update and suddenly the internet ist not Working anymore properly. Sometimes IT works for some Seconds and then again nothing even though the Network Icon in the right Corner ist showing me a valid Connection as before.

What i am also not able to do is to Upgrade my fedora30 Template. It is telling me that: Domain sys-net has failed to start. Requested Operation is Not valid. PCI Devise 0000:00:14.0 is in use by driver xenlight, Domain sys-usb

So this ist actually right. The First days With Qubes i Tried to make the UMTS STICK Work and i finally accomplished the Connection with attaching all devices from sys-net to sys-usb. My sys-usb is managing both: all my USB Connections and the Internet. I dont Unserstand why it is still asking for sys-net ?

What is the Problem With the Fedora Update and the Internet Connection? I guess Fedora cant Update because No Internet Connection that is not Working since i Made a dom0 Update today and restarted my Laptop :confused:

How can i solve this and find the Problem?
Here are two Photos one showing the Million Errors when trying to Update Fedora and the Other one my Setup.


I think the problem is that Fedora 30 and Fedora 31 have reached EOL(end of life). If you have a completely new Qubes OS installation open your dom0 terminal and type the following.

[user@dom0 ~]$ sudo qubes-dom0-update qubes-template-fedora-32
(this take some time especially if your enabled upgrades over tor)

[user@dom0 ~]$ qvm-create -l red -t fedora-32 fedora-32-dvm

[user@dom0 ~]$ qvm-prefs fedora-32-dvm template_for_dispvms True

[user@dom0 ~]$ qvm-features fedora-32-dvm appmenus-dispvm 1

[user@dom0 ~]$ qubes-prefs default-dispvm fedora-32-dvm

When you finish with the above stop sys-firewall, sys-net sys-usb and sys-whonix.

Go to your settings and change default template to template-fedora-32 and then go to “qubes-template-manager” and change all AppVMs based on fedora-30 to fedora-32.

Open your dom0 terminal again
[user@dom0 ~]$ sudo dnf remove qubes-template-fedora-30

[user@dom0 ~]$ sudo qvm-remove fedora-30-dvm

Restart sys-firewall sys-net sys-usb and sys-whonix.

Wait for the available updates. Update your system from qubes updater, restart your computer again and…
Done! :slight_smile:

Worked so far thank you :slight_smile:

Still remaining Problem updating Fedora 32 IT IS showing Green Arrow

All the Other Updates Work Just fine!

I dont know what is going on with that Fedora i Tried the Automatic updater and i Receive:
Error in updating Fedora
Failed to Download metadata for repo “Fedora modular” : cannot prepare internal mirrorlist …