Can't Update Fedora-34, Set as Default Template, Won't Update Still

I updated to Fedora 34 and I’m having the same problem, but initially typed this for Fedora 33. This is what I wrote prior to getting 34:

So I know that in order to update Fedora-33, I need to have to as the default template.

I still get this error when I do this:

Updating fedora-33

Error on updating fedora-33: Command ‘[‘sudo’, ‘qubesctl’, ‘–skip-dom0’, ‘–targets=fedora-33’, ‘–show-output’, ‘state.sls’, ‘update.qubes-vm’]’ returned non-zero exit status 20.
Failed to return clean data
Traceback (most recent call last):
File “/var/tmp/.root_dd8a91_salt/salt-call”, line 27, in
File “/var/tmp/.root_dd8a91_salt/pyall/salt/”, line 445, in salt_call
File “/var/tmp/.root_dd8a91_salt/pyall/salt/cli/”, line 48, in run
caller = salt.cli.caller.Caller.factory(self.config)
File “/var/tmp/.root_dd8a91_salt/pyall/salt/cli/”, line 64, in factory
return ZeroMQCaller(opts, **kwargs)
File “/var/tmp/.root_dd8a91_salt/pyall/salt/cli/”, line 329, in init
super(ZeroMQCaller, self).init(opts)
File “/var/tmp/.root_dd8a91_salt/pyall/salt/cli/”, line 89, in init
self.minion = salt.minion.SMinion(opts)
File “/var/tmp/.root_dd8a91_salt/pyall/salt/”, line 912, in init
opts[“grains”] = salt.loader.grains(opts)
File “/var/tmp/.root_dd8a91_salt/pyall/salt/”, line 825, in grains
ret = funcskey
File “/var/tmp/.root_dd8a91_salt/pyall/salt/grains/”, line 2384, in ip_fqdn
ret[“ipv6”] =
File “/var/tmp/.root_dd8a91_salt/pyall/salt/utils/”, line 1353, in ip_addrs6
return _ip_addrs(interface, include_loopback, interface_data, “inet6”)
File “/var/tmp/.root_dd8a91_salt/pyall/salt/utils/”, line 1333, in _ip_addrs
File “/usr/lib64/python3.9/”, line 1920, in hash
return hash((self._ip, self._scope_id))
AttributeError: _scope_id

I think I tried to make it the VM for sys-usb too to see if that could fix it and it keeps saying that it’s not a disposable VM. When I try to make it a disposable VM in dom0, that leads to errors too.

I also need to update Fedora34, so if I should avoid all this and just go with 34, let me know. I just am doing something wrong here, but I don’t know what.

Does anyone know?

What template are you using for the management-dispVM you are using in
this case?
If you manually update the fedora-34 template, does the problem still

I had installed Fedora-34 TemplateVM directly from Fedora-32, and encountered the same problem when attempting to update Fedora-34 via the Updates icon in the system tray.
I ended up activated sys-firewall after I stumbled upon the small “circular-arrow” icon under the State column in the fedora-34 listing in [Dom0] Qube Manager. I then R-clicked on the Qube Mgr listing and selected “Update Qube”. A window opened, and the update completed with no errors.
Hope this helps . . .

I’m having the same problem and this did not work for me.

Fedora 34 is still being tested. The fedora-33 is the currently supported version.

yes, sorry, I’m having the problem with 33. The first time this happened, a simple reboot did the trick, but not this time.

Would you be able to open that as a separate issue? There may be a little variation since fedora-33 is supported and should work.

Sure. The OP said he was originally talking about 33 so I assumed it was the same problem.

Ah I see. Then let’s keep it here. udpated the title

I experienced the same issue (same stack trace) attempting to update a Fedora 33 template when the default-mgmt-dvm was set to a Fedora 32 template.

Since Fedora 32 was being retired, I set Fedora 33 as the template for default-mgmt-dvm (with Qubes Template Manager) and no longer encountered the issue.

Yeah, that’s not the issue. I did that a while ago.

oh, I just noticed that my error message is slightly different:

Error on updating fedora-33: Command '['sudo', 'qubesctl', '--skip-dom0', '--targets=fedora-33', '--show-output', 'state.sls', 'update.qubes-vm']' returned non-zero exit status 20
            ID: /usr/lib/rpm/macros.d/macros.qubes
      Function: file.managed
        Result: True
       Comment: File /usr/lib/rpm/macros.d/macros.qubes is in the correct state
       Started: 20:09:22.724421
      Duration: 45.063 ms
            ID: dnf-makecache
      Function: cmd.script
        Result: False
       Comment: Could not create DNF metadata cache
       Started: 20:09:22.771434
      Duration: 124052.848 ms
            ID: update
      Function: pkg.uptodate
        Result: False
       Comment: One or more requisite failed: update.qubes-vm.dnf-makecache
       Started: 20:11:28.550772
      Duration: 0.012 ms
            ID: notify-updates
          Name: /usr/lib/qubes/upgrades-status-notify
        Result: False
       Comment: Command "/usr/lib/qubes/upgrades-status-notify" run
       Started: 20:11:28.550903
      Duration: 127059.677 ms
                    Error: Failed to download metadata for repo 'updates': Cannot prepare internal mirrorlist: Curl error (56): Failure when receiving data from the peer for [Received HTTP code 500 from proxy after CONNECT]
  Summary for fedora-33
  Succeeded: 1 (changed=1)
  Failed:    3
  Total states run:     4
  Total run time: 251.158 s

@obiwanzanobi just added some (markdown) formatting to you post to make the text more readable.

Tip: You can also do so in the future either by using the </> button in the editor or using markdown direclty.