Can't Register my Sip Account

Good morning and happy New Year to all.
I’m new on Qubes OS and I can’t register my Voip Account with Zoiper as I did with my old Ubuntu laptop.
I downloaded free version of Zoiper 3 and when i try to create a Sip account filling up with Username, Password and domain Zoiper falls to register it and it says “We are sorry we are unable to connect to your PBX with the information you provided”!.
The information are correct, I already sent an email to the voip company but I am still waiting for a reply.
Hope somebody can help me because I am getting crazy :smiley:


At first glance, it seems unrelated to Qubes OS itself :thinking:

In which qube did you run this command? If you tried in a template, that’s normal it’s failing as they don’t have access to the network, and not meant to be used like this.

Sorry I didn’t explain all the thing.
I cloned a debian template where i Gave access to internet for few minutes just the time to install Zoiper.
Then I shutdowned and created a qube linked to that template where I added Zoiper in the app.
I run it and tried to register the account I have been using for a while without problem on ubuntu but it fails to register.

Even for few minutes, you could compromized the template :confused:
I don’t use Zoiper but I think the better thing is to try creating a standalone based on debian and install Zoiper in it then, you could access to internet without compromized your template and see if it’s working…

Ok will try even if is safer don’t think will solve the problem

Is it actually connecting to a local PBX on the local network? If so, maybe the PBX tries to connect back but it hits sys-net which won’t forward the traffic.

Yes exactly

To make it work, you have 4 tasks:

  • figure what network ports are used by your PBX or the protocol
  • NAT these ports from sys-net to sys-firewall
  • NAT these ports from sys-firewall to the destination qube
  • Allow the traffic for these ports on the destination qube

It’s not really hard, I wrote a guide for this Qubes OS 4.2 nftables / nft firewall guide

It’s also explained in the official documentation Firewall | Qubes OS (I updated it recently for Qubes OS 4.2)

Thank you for Help, for me would be a milestone but I will figure out how to fix it :smiley:

If it’s figured out, please don’t forget to post the steps for easier future configurations.