Can't launch firefox from appvm menu

Updated template to fedora 38. but I am unable to load firefox from the qubes appvm menu. I’m only able to launch it from the terminal by typing firefox. How can I fix this?


It’s possible that, in your upgrade, your new template is using technically a different Firefox package than your old template. I would open the Qubes Manager Tool, then go to the AppVM you are having trouble with and right-click, and then go into Settings.

Under that menu there is a tab call Applications, and I have found sometimes I need to manually refresh the Application list using the button in there, and then make sure the firefox package you are using on the right side of the menu does not say “Application missing in Template”.

As a temporary fix, you can edit the Firefox shortcut in the TemplateVM and add # on the line that begins with DBusActivatable

sudo nano /usr/share/applications/firefox.desktop


I’m having the same issue as @CooloutAC. It’s impacting fedora-38 AppVMs and DVMs. When I did as @moonlitOrca suggested, I didn’t see any “application missing” message on the right side. However, I did notice that in addition to the “Firefox” option (right-side; selected), there is now “Firefox on X11” and “Firefox on Wayland” on the left side (available). I tried those other options as well, but they won’t launch from either the menu or terminal. Normally, I use i3, but I observed the same issue in xfce.

@qubes, your temporary fix worked for me. Is this something that will likely be in a future template update? Thank you again for your help.

1 Like

@qblast37 same here. @qubes ty I will try that

Could it be this?