Can't launch any qube's/template app - 4.2, KDE

Application menu > any qube/template > any app, except the settings > it starts the qube and the app, I can see the app(terminal for example) appear in task manager, but it disappears short after that and it doesn’t launch the app. The qube starts and doesn’t shut down(as expected).

4.2, KDE

1 Like

Am I the only one who have this bug?

Or perhaps the ones who use KDE didn’t upgrade yet?

I am using KDE and have had issues adjacent to yours. I’m running KDE and upgrade to 4.2. I posted about it here if you want to look at what I’ve found and see if any issues similar to yours.


But you say you can open terminal of some random qube/template?

At the very least there’s seem to be a problem with the kde-settings-qubes, as it fails to install something.

I just hope Qubes’ team won’t drop support for KDE and fix this. Was so exited about upgrading to 4.2, but sadly that broke the system entirely.

Yea. It’s weird. When you open up the Qubes Manager, are you able to interact with the AppVMs via the console?

I have similar experience. Some app can be started from the application menu ( like tor browser ), but others (like thunar) have to be started via the Qubes manager widget.

I reinstalled Qubes again and when I tried to install KDE, it shows errors during the installation process:
Running scriptlet: kde-settings-qubes-5.12.3-8.fc37.noarch
/var/tmp/rpm-tmp.EZgLSP: line4: patch: command not found
warning: %triggerin(kde-settings-qubes-5.12.3-8.fc37.noarch) scriptlet failed, exit status 127
Error in <unknown> scriptlet in rpm package kde-settings-qubes

Just to make it clear: it’s a fresh install, no prior changes are made to anything. Just selected so the sys-net or sys-usb will be disposable and this time tried latest kernel(didn’t change much)

@corbeaucrypto I can’t even open qube’s console.

How is it possible I’m the only one affected? Did you guys upgrade from 4.1 or did fresh install of 4.2? I was almost sure it’s not only me prior creating this topic.

I did an upgrade. So not really sure what’s happening on your box.

I ran into this exact issue with a new install and the problem was that the default session of SDDM is KDE Wayland instead of KDE X11.

If you make sure to start an X11 session then windows do display properly.

Support for Wayland is an open bug: Support KDE Wayland Session · Issue #8515 · QubesOS/qubes-issues · GitHub