Can't install with GPT partition scheme

Hi :slight_smile:

I’m trying to install Qubes with GPT partition scheme. I need the GPT partition scheme since I need to dual-boot with my Windows installation, which is in a different disk that uses a GPT partition scheme.

This is my motherboard: B550 AORUS PRO (rev. 1.0) Gallery | Motherboard - GIGABYTE Global

I’ve downloaded the official ISO from the website and created an USB stick with the following command:
sudo dd if=<path-to-my-iso> of=/dev/sdY status=progress bs=1048576 && sync
(where Y is my device letter)

I’ve disabled secure boot.

After doing so, if I boot with CSM enabled (legacy) I can boot in the first partition of the USB stick and install Qubes as expected, but it can only install with MBR partition scheme.

I’ve read that Qubes only installs with GPT partition scheme if you boot it in UEFI mode (with CSM disabled).

After that, I’ve tried to disable CSM (legacy). But, when I select to boot on partition 2 the following message appears in a black screen:

Xen 4.8.5-30.fc25 (c/s ) EFI loader
Using configuration file 'BOOTX64.cfg'
vmlinuz: 0x00000000b71d4000-0x000000000b78b9480
initrd.img: 0x00000000b3588000-0x00000000b49b1410

After that message appeared, the computer restarts (without entering the setup)

I’ve read in the UEFI troubleshoot guide that I need to tweak the BOOTX64.cfg file a little (commenting a few lines) for it to work in some motherboards. But, I’m not being able to do that.

The USB stick that I’ve created is, for some reason, read-only, and I can’t mount it with write enabled. I’ve already tried using hdparam and I’ve already tried with 4 different USB sticks, but it simply won’t mount with write enabled (also, my USB stick does not have any physical lock).

So, I can’t edit the contents of the /EFI/BOOT/BOOTX64.cfg file, since I can’t edit anything in my USB stick after creating it with dd

If I use Rufus, instead, and I don’t select to use DD, I can edit the contents of the USB stick files, but it won’t start the installer. After commenting the lines at qubes-verbose it passes from the previous error screen, but it enters a different error loop, that (according to the UEFI troubleshoot guide) is related to me not using DD to create the USB stick.

My last attempt was editing the ISO contents, changing what I need in that file. I used ISO Master for that, but as soon as I edit the ISO file and them I use DD to copy those to my stick, I was not able to boot from that stick anymore. So, no luck.

Anyone can help me?