Can't install software - "Extraction failed. No space left on .1107"

I’m trying to install software (Mathematica) that was downloaded from the developer’s website. It is a 5 GB .sh file in the Downloads folder of the PVH standalone I set up (based on Debian 11) specifically to run this software. I set up the qube with 6 GB of private storage, 50 GB of system storage, and initial memory of 5120 MB.

Terminal input:

cd Downloads

sudo bash

Terminal output:

Verifying archive integrity.

Extracting installer…

…Extraction failed. No space left on .1107

Removing temporary files.

I’m looking through the other forum topics but not having much luck finding something directly applicable. Thanks for any ideas.

Your qube has only 6 GB of private storage, and you are trying to extract from a 5 GB archive, so it is possible that you are simply running out of space. Increase private storage to 10 GB or higher and try again.

1 Like

Thank you adw. That worked! (sort of)

I bumped it to 15 GB and got past that hurdle. The next issue was an error saying that it couldn’t install it in the default directory “/usr/local/Wolfram/Mathematica” because there wasn’t enough room. I assigned it to a new directory “/home/user/Software/Mathematica” and tried again - got the same message. I decided to expand the memory from 15 GB to 25 GB. The developer website states that the system specification for hardware disk space is 19 GB… I assumed this was the system storage, but it seems that it needed to be set in the private storage instead.

Thanks again for your help. Now I know disk space requirement = qubes private storage. Hopefully someone else can benefit from that too.

This is a particular case, not general.
The reason is that /usr/local in a qube is stored on the private storage,
as you have discovered, and Mathematica installs by default in to
/usr/local, which is somewhat unusual.

Many users think that private storage = home directory.
It’s a little more complicated.
Private storage is actually /rw.
If you look in /rw you will see that it contains some config
directories (to allow specific qube configuration), home and
The last two are bind mounted over /home and /usr/local.

So anything you install to /usr/local will be stored in /rw and forms
part of the private storage.
Mathematica does this by default, but you can use this feature to install
other software on a per qube basis, provided you can specify the install
directory. (There’s often a targetdir parameter - Mathematica has


Thank you for the explanation unman. So even though I tried to move the directory, it didn’t work because I put it in the /home directory - still part of private storage. This is great insight for future installs. Thanks again.