Can't install Qubes because there are "No disks detected"

Hello! This, honestly, looks like a silly question to me, but I’ve looked on the Installation guide, on the search engine (even searched for Anaconda) and I can’t find a solution for the error I have when I’m on the main install page, at Installation destination. When I click on it, there is no local disk showing. I refreshed, nothing. I made a 36,8GB NTFS partition made on my Windows 11 (over 32GB), but still no disk showed on the install page. The error sounds exactly like this: “No disks detected. Please shut down the computer, connect at least one disk, and restart to complete installation”. My disk is also on a GPT structure, if that helps. I want to make a dual boot with my WIndows 11 OS. What should I do to fix this? Thanks!

Do you have RAID enabled in BIOS?

Yes. I’ve heard issues about having RAID enabled during installation of qubes, but BIOS warns me that switching between raid and ahci can cause malfunction.

I can’t comment on safety of switching from RAID to AHCI.
This issue is likely due to installer missing the raid driver. Maybe you can find and load the driver in installer for it to see your raid.

It’s also just barely possible that even after you eliminate RAID you will find that the installer simply cannot see your SATA devices. (This happened to me.)

If so it’s likely that QubesOS won’t be able to see them either (so moving your target drive to another box and installing QubesOS there, then bringing it back to your original machine, won’t work).

If that’s what’s going on (and I emphasize it probably is not), all hope is not lost.

I had never run Qubes before and wasn’t sure how much I’d like it. But I was able to install to a thumb drive (USB 3.0 or you will die waiting for it to boot) and establish by running from that, that I wanted Qubes enough that it was worth buying new hardware for it. (I don’t know if you’re totally new to Qubes or not.)

It’s fair to say I liked what I saw, a lot.

Hi, I’m encountering the same issue.
However, the BIOS on my Asus says I have “non-raid” physical disk. It doesn’t say anything about AHCI specifically.
Any idea what I should do?

What’s your ASUS model?

Asus Vivobook 15 (X1504VA)

The malfunction here refers to a potential issue if you have an installed operating system. Switching between RAID and AHCI can change the disks UUID or numbering. There is no danger or physical harm switching those options.

DId you disable Secure Boot?
What do you have in Advanced\SATA Configuration?

Secure boot was already disabled. Your Bios Utility looks different than mine - I have something called “My Asus in UEFI”
Added the list of the options under advanced

What do you have in VMD setup menu? Can you disable VMD?


I disabled it, and it worked :smiley:

1 Like

Thank you for your help! I switched to ACHI using this tutorial Switch RAID to AHCI without reinstalling Windows 10 - Super User and now my disk is detected. :grin:

1 Like