Can't Install BitMessage

I can’t install BitMessage.

user@host:~/PyBitmessage/src$ python
ERROR: The msgpack package is not available.It is highly recommended for messages coding.
ERROR: On Debian, try running "apt-get install python-msgpack" as root.
Loading existing config files from /home/user/.config/PyBitmessage/
Using default logger configuration
2022-02-16 [time] - CRITICAL - PyBitmessage requires PyQt unless you want to run it as a daemon and interact with it using the API. You can download it from Riverbank Computing | Download or by searching Google for 'PyQt Download' (without quotes).
Traceback (most recent call last):
File "/home/user/PyBitmessage/src/bitmessageqt/", line 5, in <module>
from PyQt4 import QtCore, QtGui
ImportError: No module named PyQt4
user@host:~/PyBitmessage/src$ sudo apt-get install python-msgpack
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
E: Unable to locate package python-msgpack

i follow this guide

and fail

@sven this is qubes specific because in whonix this work, but in qube it doesn’t and am trying to work in qube

also i did install all dependancies in whonix-ws-16 and they downloaded there. but i still get error message in anon-whonix. yes restarted everything. many time

@qubesn00b did you install

sudo apt install git python3 openssl libssl-dev python3-msgpack python3-qtpy

as outlined in the Whonix link you posted. Note that it is python3-msgpack.

it’s installed in whonix-ws-16 already

i checked again

user@host:~$ sudo apt install git python3 openssl libssl-dev python3-msgpack python3-qtpy
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
git is already the newest version (1:2.30.2-1).
libssl-dev is already the newest version (1.1.1k-1+deb11u1).
openssl is already the newest version (1.1.1k-1+deb11u1).
python3-msgpack is already the newest version (1.0.0-6+b1).
python3-qtpy is already the newest version (1.9.0-3).
python3 is already the newest version (3.9.2-3).
0 upgraded, 0 newly installed, 0 to remove and 11 not upgraded.

anon-whonix doesn’t seem to think it’s there

and yes, it’s using whonix-16-ws as the template

@sven, what am i doing?

What happens if you try to run it in anon-whonix proper, not a dispvm based on it?

qvm-run anon-whonix xterm &

… and then try to run it in there? Obviously you are not supposed to run things in your dispVM template, but you could make a backup/clone.

I am using anon-whonix proper

The instructions didn’t say to install in the disposable template. Should I have done that?

In a disposable whonix-ws-16-dvm, there’s no directory for the program

i’m almost ready to give up on qubes and go back to a more easier operating system, something for average simple-minded user like arch

@qubesn00b I don’t have whonix installed at the moment so I mixed up the name. However under qubes the roles of the VMs are always the same:

  • template (e.g. whonix-ws-16)
  • AppVM (e.g. anon-whonix)
  • AppVM that is used as a template for a DispVM (whonix-ws-16-dvm)
  • DispVM named dispXXX

So I was confused about where you are trying to run the program. I now understand that anon-whonix is a AppVM based on whonix-ws-16. You installed all dependencies in whonix-ws-16 and then when you try to run your python program in anon-whonix you get the above error – is that correct?

What do you mean by that? Have you tried it in a WHonix workstation under VirtualBox? Why wouldn’t you ask in the Whonix forum? … they wrote the guide including the Qubes OS part.

Not sure I can help you with this one (I haven’t spent much time with python stuff).

you are correct

i wrote above because sometimes people ask question and people respond “go other forum this is not qube specific” but this problem in qube and there is nowhere else for me to go

The reason that people say that is that the Whonix devs have asked that
Qubes-Whonix questions be asked in those forums rather than here. (This
is because they monitor those forums more closely and so you are more
likely to get an informed answer.)

1 Like