Can't get sys-whonix to work in 4.1

I know that 4.1 is still pre-alpha, but I didn’t see this issue reported. This is a new, fresh install of 4.1 which works generally well, but I just can’t get tor to work. Trying to update whonix-gw and whonix-ws results in inability to get reach the mirrors. I’ve confirmed that sys-whonix is running, but trying to do anything within sys-whonix is impossible. For example, if I run from dom0 “qvm-run sys-whonix xterm” then no xterm appears (although the command won’t return in dom0 until i Ctrl-C.) Similarly, trying to run any program from the sys-whonix menu gives no response at all.

As this is a fresh install without modification, it’s hard to imagine that I did anything wrong. Is this a known 4.1 issue, or is there something else I need to do to get sys-whonix (and therefore tor) working?


I have got the same error. Tried installing qubes 4.1 with different settings. One time sys-net as dispvm and everything, and custom storage pool ,too, the other time with standart settings, but I cannot update sys-whonix. it is running at the start up, but cannot be updated. maybe there is a solution for this how to get it working in the alpha. I really love the alpha,because much thins are running very good for an alpha and it as a big potential :slight_smile: stay blessed

I got a bit more success, starting the xfce terminal and running sudo apt update && sudo apt upgrade. So my sys-whonix can be updated. I installed the qubes current testing repo, after the fresh install, and this fixes a few things, with my audio, cam ,networking in Windows Hvm’s and few things more.


I have the same problem. No GUI items seem to come through from any whonix-gw-15 based VMs. I can get console output with qvm-run --pass-io sys-whonix <command> but that is about all. I can not even update, because I never see the window for the first-run configuration wizard, and thus can not set TOR running.

When I shut down sys-whonix (or other VMs with the same template) I get a notification similar to:
Denied: whonix.NewStatus+sys-whonix_shudtown from sys-whonix to sys-whonix

@tel I think this will gone wonderful project i ever seen before this. As this is a fresh install without modification i have wasted my time on it. :slightly_smiling_face:

i have seen the dispvm setting for sys-net in the installation menu. i have never been able to understand the pro and con of this feature. do you mind explaining the benefit and negative of this variable?

i will test the 20210424 test release soon and comment if the issue has persisted.

fresh after install with image from 3rd july it worked until i upgraded everything. (via qubes-update-gui) now only the update proxy works but no whonix dvm, or anything else i want to put thru sys-whonix

Same problem here.
Did you find a solution? Or anyone else?
I tried 4.1: Whonix WS failing · Issue #6597 · QubesOS/qubes-issues · GitHub, but that did not help.

As far as is grasp it, WS is booting and doing everythinng it shoudl but GW isnnt proxying. i conected a Fedora VM to GW and it did nothig, i expected it to proxy but i am not to familiar with the function of GW and it is supposed to block things. either way nothing else except update proxy seem to work.

Please check that IPV6 is disabled in sys-whonix. You can take it a step further and disable IPV6 system wide, either in your router settings or using the network manager sys-tray icon → edit connections, select your connection, goto IPV6 tab and switch to disabled. That is if you do not mind not using IPV6. I have ran the alphas with all testings repo’s enabled and am on the latest beta, and have no trouble with sys whonix at all.

1 Like

this was my solution, thenks.

qvm-features VMNAME ipv6 ''
1 Like