Can't get QubesBuilder to download components

I’m currently trying to build the 4.1.x branch in order to apply the Xen patch listed in this issue. The Xen build works fine, but midway through the build it fails on desktop-linux-awesome.

This failure is probably some trivial misconfiguration, but troubleshooting it is a pain because every time I run make qubes it wants to rebuild every other component that already got built successfully. And, if I try make iso after this only-partial success then it fails for lack of one of the VM RPM files. If I interpret the docs correctly, the USE_QUBES_REPO_VERSION configuration option should allow me to use prebuilt versions of the non-Xen components. But if I enable that option and then remove the non-Xen entries in the components list, it builds only Xen and then fails again when I try to build ISOs.

How can I fix this without re-running the multiple-hour build process over and over?

If you turn on debugging and increase log verbosity, then you should be
able to identify exactly what the issue is with your download.

You still need the components in builder.conf - don’t remove them.
Using the USE_QUBES_REPO_VERSION option instructs the builder to hit
the repos instead of building components.

As to your build problem you can build individual items - try make and
you’ll see a list of available targets, then build each component as
you will by specifying the component , like make app-shutdown-idle.
You can also build just the vm component -
make app-linux-pdf-converter-vm - or just the dom0 component.

You could also comment out the components you have already built in


I’ve since managed to get it working by specifying a long list of components on the make command line. However, it still doesn’t seem to be downloading anything. How do I explicitly use the version from the repo rather than a local build for a given component?