Can't Get Mic to Work in 4.1, Are There Compatible External USB Sounds Cards?

I am unable to get my mic to work in Qubes.

I am able to see the sound card in the configuration, and I am able to see some electrical noise showing as incoming sound, but the Mic doesn’t detect audio. I have tried different microphones. I am able to hear audio.

Are there any external USB soundcards that almost always work with Qubes? I would prefer something smaller and I don’t need anything extremely complicated, but would prefer at least 24-bit sound that goes up to at least 22 kHz with somewhat low latency for online classes.

Any one know of anything that will work? I just need an external USB sound card that will show up in Qubes and allow to record and listen to audio for class.

Not sure what you are looking for exactly, but I had the same problem (microphone not working) so I use a Jabra SPEAK 410 for PC (it’s a USB connected speaker/microphone combination) for all my video conferencing. Works fine with Qubes 4.0, so I would expect work with 4.1.

Maybe a red herring, but is the qube you’re connecting the mic to a minimal template?

Try checking settings with pavucontrol in dom0 (the speaker icon/“audio mixer…”) as well as in the VM (might need to install pavucontrol explicitly in the template, can’t remember).

In dom0, you want to ensure:

  • Configuration tab: make sure the selected profile defines an input [or duplex]
  • Input devices tab: Make sure the port is correctly set and that it is not muted (speaker with X), also mark it as the fallback; ensure gain is sufficient
  • Recording tab: Make sure the qube has the same profile selected, and is not muted

In the qube, make sure the Qubes VCHAN Source input device is fallback and unmuted.

Does this show up in the dom0 panel automatically or do you have to add it to VMs as a USB add on and then get it to show up by using terminal commands?

It’s difficult to provide support without more information, e.g:
First off, can you clarify:
Does dom0 pass the device to the VM?
Does the VM recognise the device?
(see: How to use USB devices | Qubes OS for support)

If above fails:
How modern is your hardware?
How modern is the microphone?
What template is sys-usb?
What template is the VM you are trying to connect the mic to?
Are you using kernel-stable or kernel-latest for 4.1?

dom0 will add it via USB. It isn’t recognized there, but I haven’t run the commands inside terminal to get pavucontrol working. Some of these Qubes are Windows qubes and there’s no terminal.

My hardware and microphone is all somewhat modern, from the last 5 years.

Fedora 34 is sys-usb.

I am trying to connect to different VMs.

I’m fc32

If I get the external soundcard to attach to some Fedohe ra Qubes, I don’t think this solve a problem because then I can’t use in Windows

I would like to know if there is any external sound card wthat automatically attaches to dom0. I dont want to get new usb external card only to have same problem of no ability to configure in windows terminal.

i can get sound in windows qube by qvm-features WindowsVM1 audio-modle ich6, but need dom0 for the audio input

i’ve tried more than 1 audio input, there is never any perception of audio from dom0 from the input. i think it is internal soundcards

I have to add it to the VM as a USB device. Then I just select it in the software that’s needs to use it. No terminal commands needed (at least for Zoom and Teams)

1 Like