Cant find xen.efi ti copy to BOOT

Hi all, I’ve been booting Qubes from USB on my windows PC for the last few months and it has become my primary OS. I want to boot from the same USB on my Gatec s410 laptop(which I do not see on the supported list). The laptop has Ubuntu installed on the hard drive. Upon entering boot setup, I do not see a Qubes boot option in the bios. I have read the UEFI troubleshooting, and can not find the xen.efi file to copy to BOOT. On the first partition which has 21 files including an empty efi folder, the xen.config, as well as gz and image files. I can not find the xen.efi. I am unable to access the second partition, when mounting it ask for a password which i enter correctly and then it closes and removes it from the mountable list. Any help would be appreciates as I’ve been trying to resolve this issue for over a week. The bios is InsydeH20 and Legacy mode is enabled, Boot from USB is selected. Any help is appreciated.

Welcome to the forum. :slight_smile:

If you have Ubuntu on the laptop, then you might be able to just use the GRUB to load the config for Qubes - like in:

If the GRUB menu is hidden on the laptop, boot into Ubuntu and edit the file /etc/default/grub and comment the line GRUB_TIMEOUT_STYLE=hidden and run update-grub - on the next boot, you should have the GRUB menu. :slight_smile:

Yes, Qubes was installed with a boot partition I beleive. The grub menu was hidden, commented and ran update-grub. thx. I need to leave for 2 hours. Will continue this afternoon.

I changed hidden to menu in the grub file and adjusted the timeout from 0 to 1000, i am now in the grubs menu. I hit “c” then tab and do not see “file system type”. It shows a list of possible commands

You probably solved it long time ago - but just in case others should read this thread in the future:

  • press c at the GRUB menu, to get to the GRUB prompt
  • type:
    configfile (hd
  • press tab to see the list of partitions that GRUB knows about

You can try each in the list and look for the /efi/qubes/grub.cfg file on them.


  • This is for QubesOS 4.1 – I’m pretty sure QubesOS 4.0 was different.
  • It assumes EFI boot - I’ve not tried legacy boot.
  • This only tries to boot from you USB device - there might still be issues with support for the laptop.

Thanks for the help so far. The drive with qubes installed is “sdb”. The only partition i am able to mount in gui is the " sdb2" this contains an empty efi folder as well as 20 other items including a grub2 folder. Partition 1 does not show, and Partition 3 is unable to mount and disappears after telling me it can not mount. What is the correct syntax to find the config file in the grub command prompt? Is it “/dev/sdb1/efi/qubes/grub.cfg”?

ChrisA- “configfile (hd” then tab to see list of partitions that Grub knows about, did not show a list, it instead gave me a list of possible commands. I found the drive via lsblk command

This is QubesOS 4.1, Legacy boot enabled seems to be locked in my bios.

thx again

The drive with qubes installed is “sdb”.

Sounds like you booted the Ubuntu, rather than use the installed GRUB to load the config from the usb stick. What a booted Ubuntu sees, doesn’t matter … what is accessible from the GRUB prompt does. :slight_smile:

ChrisA- “configfile (hd” then tab to see list of partitions that Grub knows about, did not show a list, it instead gave me a list of possible commands.

Did you type configfile (hd before pressing the tab-key? It’s correct that GRUB will give you a list of commands, if you press tab before you starts typing anything - and if you type co before pressing tab, you should have the options like configfile, continue and coreboot_boottime.

I found the drive via lsblk command

lsblk sounds like a booted system - GRUB uses different names for the drives (like hd0, hd1) and partitions (like hd0,gpt1 or hd1,gpt4), so doesn’t help. :-/

I was hitting enter after configfile (hd, then tab…
Does this look correct?

It looks better … the next test is to try:

configfile (hd1,

and then hit tab – it should give you a list of partitions on hd1 that GRUB knows (like hd1,gpt1,hd1,gpt2,…). Try each like:

configfile (hd1,gpt1)/efi/qu

and hit tab – if it completes to configfile (hd1,gpt1)/efi/qubes/ then add grub.cfg so it bekomes

configfile (hd1,gpt1)/efi/qubes/grub.cfg

– and if it doesn’t completes, try with (hd1,gpt2)/efi/qu (repeat for each partition on disk hd1 – if no match, try with hd0). :slight_smile:

When you have a match, press enter and you should see the GRUB-config from the USB stick and be ready to try a boot.

Thx, working on it.

When i hit enter it sends me to a new black screen with grub> _
When i hit tab it repeats the line

The combo:

Partition hd1,gpt1: Filesystem type fat, ..
Partition hd1,gpt2: Filesystem type ext* - ...

looks like Ubuntu – can you check the partitions on hd0?

I would expect to see something with 3 partitions, for the Qubes OS disk - like:

Partition hdX,gpt1: Filesystem type fat, ...
Partition hdX,gpt2: Filesystem type ext* - ...
Partition hdX,gpt3: No known filesystem detected - ..

That could very well be your Qubes stick – have you remembered to disabled “secure boot” on this laptop (in BIOS)? :wink:

I do not see an option to secure boot

Sounds like it should be under the Security tab (?):

1 Like

Ty much will look into tomorrow. Here is the securiry tab.

I was able to change the secure boot to disabled after creating a supervisor password. After entering (hd0,gpt1)/efi/qubes/grub.cfg Qubes started. When I restarted the cpu, I do not see Qubes as a boot option in Grub and must configfile in command again. Is there a way to display it? Is this what you were talking about with: menuentry “Give me QUBES” { insmod xfs search --set=root --lab? Where would I add that?

When I try booting on my desktop, I am able to choose it from my boot menu, then the hypervisor loads, i enter the password for disk encryption, then the screen goes black and the computer resets. I have been using this drive on my desktop for months without any issues. I think booting it on my laptop changed something…

Yes - the changes are temporal for one boot.

To add it permanently, you can boot Ubuntu, edit the file /etc/grub.d/40_config and add the lines (replace X and Y accordingly):

menuentry "Give me QUBES" {
   configfile (hdX,gptY)/efi/qubes/grub.cfg

and run update-grub. On the next boot, there should be a entry called “Give me QUBES”. :slight_smile:

1 Like