Can't enable rpmfusion in fedora-33 (not installed by default?)

Hi,

I need to enable rpmfusion repositories but I can’t.
I got fedora-33 template by in-place upgrade

According to:

and

and

https://rpmfusion.org/Configuration/

I tired:
1.
sudo dnf install --nogpgcheck https://mirrors.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm https://mirrors.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm

Warning: Enforcing GPG signature check globally as per active RPM security policy (see 'gpgcheck' in dnf.conf(5) for how to squelch this message)
Last metadata expiration check: 1:06:28 ago on Thu Jun 24 08:58:03 2021.
rpmfusion-free-release-33.noarch.rpm                                                                                                                                                                           11 kB/s |  11 kB     00:01    
rpmfusion-nonfree-release-33.noarch.rpm                                                                                                                                                                        12 kB/s |  11 kB     00:00    
Dependencies resolved.
==============================================================================================================================================================================================================================================
 Package                                                                Architecture                                        Version                                           Repository                                                 Size
==============================================================================================================================================================================================================================================
Installing:
 rpmfusion-free-release                                                 noarch                                              33-1                                              @commandline                                               11 k
 rpmfusion-nonfree-release                                              noarch                                              33-1                                              @commandline                                               11 k

Transaction Summary
==============================================================================================================================================================================================================================================
Install  2 Packages

Total size: 23 k
Installed size: 11 k
Is this ok [y/N]: y
Downloading Packages:
warning: /var/cache/dnf/commandline-d27c1cfc10149c68/packages/rpmfusion-free-release-33.noarch.rpm: Header V3 RSA/SHA1 Signature, key ID d651ff2e: NOKEY
warning: /var/cache/dnf/commandline-d27c1cfc10149c68/packages/rpmfusion-nonfree-release-33.noarch.rpm: Header V3 RSA/SHA1 Signature, key ID 94843c65: NOKEY
Public key for rpmfusion-free-release-33.noarch.rpm is not installed
Public key for rpmfusion-nonfree-release-33.noarch.rpm is not installed
Error: GPG check FAILED

Import somehow gpg keys but couldn’t find proper one as they changed to year based ones? I don’t know The instructions on rpmfusion are quiet unclear for me.

Enable them in dnfdragora and by cli but they seems not to be installed.

Could you help me please :slight_smile: ?

Try following this:

https://www.qubes-os.org/doc/how-to-install-software/#rpmfusion-for-fedora-templates

2 Likes

Thanks for reply, here is output for rpmfusion-free and rpmfusion-free-updates

[user@fedora-33 /]$ sudo dnf config-manager --set-enabled rpmfusion-free
Warning: Enforcing GPG signature check globally as per active RPM security policy (see 'gpgcheck' in dnf.conf(5) for how to squelch this message)
Error: No matching repo to modify: rpmfusion-free.
[user@fedora-33 /]$ sudo dnf config-manager --set-enabled rpmfusion-free-updates
Warning: Enforcing GPG signature check globally as per active RPM security policy (see 'gpgcheck' in dnf.conf(5) for how to squelch this message)
Error: No matching repo to modify: rpmfusion-free-updates.

Thanks for reply, here is output for rpmfusion-free and rpmfusion-free-updates

There are 2 issues here.

The warning arrives because of your configuration. You can fix this by
doing what it says - look at man dnf.conf in the qube you are using
for updates.
Alternatively you can search for that exact warning “Enforcing GPG
signature check globally as per active RPM security” in the forum, where
you will find a full discussion.

The Error arises because you don’t have Fusion repositories defined in
/etc/yum.repos.d.
You could have discovered this by searching for that Error on the web.
You can fix this by copying the definitions from a standard Fedora
template in to your template.
But why don’t you have those repositories? They are defined in a
standard Fedora template (but not enabled). They aren’t defined in a
Fedora minimal template.
That makes me think you started with a minimal template. If you did

  • don’t do this. The minimal templates are intended for advanced users,
    and carry a health warning. If you didn’t - I’m at a loss for an
    explanation.
1 Like

i had the same problem as @BBro, then i realiazed that i was using minimal…

1 Like