Can't create module-vchan-sink virtual audio output on standalone VM

Hello. I am trying to solve a problem on a Qubes standalone VM I created, but it is being a big difficulty for me. I had read the Qubes documentation (here: Audio Virtualization | Qubes OS) about it, but I still unable to create a module-vchan-sink virtual audio channel on my Manjaro Linux standalone VM. After some weeks trying I decided to ask for help for you guys. Even with a pre-installed PulseAudio on Manjaro, I could not create a virtual output to dom0 (maybe because I don’t know how to use PulseAudio `_(ツ)_/´ ). My main problem is that there is no audio on my Manjaro standalone VM, and I think a lacking virtual channel between Manjaro and dom0 is the cause. I would be glad if someone give me a tip.

I think a lacking virtual channel between Manjaro and dom0 is the cause

You need the respective Qubes packages (pulseaudio-qubes at the very
least) to make that work. Since Manjaro is based on Arch, chances are
good the packages provided by @unman will work for you.

The packages are here:

1 Like

Tks. I have downloaded the qubes-vm-pulseaudio-4.0.36-10-x86_64.pkg.tar.zst file, its signature, and unman Public Key, but gpg is not verifying… It just sends the message “Using RSA key [weird-key-i-dont-know-where-it-came-from]” and "impossible to verify signature: no public key. But when I use gpg --list-keys, unman’s key is there. Am I doing something wrong?

It sounds like you added unman’s key to your gpg public keyring but have
not given it to the package manager. It has likely it’s own place for
those. I could tell you where that is for debian/apt but I don’t know
how that works for Arch.

However, Arch has excellent documentation (really the best in my opinion
– I use it all the time to learn general Linux things). So it shouldn’t
be hard to find. I’d search for “Arch add key package manager” maybe
with “rpm” if that’s the package manager used there.

Good luck!

(There is also a chance @unman sees your post and gives you a nudge in
the right direction :wink:

1 Like


1 Like

Hey guys… tks for helping but… It is not a problem in my Manjaro VM. I have made a Debian VM to check the signatures but gpg is giving me the same error message with the Debiam VM. I don’t know what’s going on. Just to be sure, I’m sending unman’s pulseaudio file, its signature, and the key. Are you guys receiving the same error message?

My steps (in Debian) were:


gpg --import gpgkey.asc

gpg: key 0C6D15D5E0A9816E: 3 signatures not checked due to missing keys
gpg: key 0C6D15D5E0A9816E: public key "unman <>" imported
gpg: Total number processed: 1
gpg:               imported: 1
gpg: marginals needed: 3  completes needed: 1  trust model: pgp
gpg: depth: 0  valid:   1  signed:   0  trust: 0-, 0q, 0n, 0m, 0f, 1u


gpg --verify qubes-vm-pulseaudio-4.0.36-10-x86_64.pkg.tar.zst.sig qubes-vm-pulseaudio-4.0.36-10-x86_64.pkg.tar.zst

gpg: Signature made Sun 06 Jun 2021 12:27:56 AM -03
gpg:                using RSA key 7473414DF9A181A45244BDACFDD1B8244731B36C
gpg: Can't check signature: No public key

Here are the files:

Pulseaudio file and signature:

Unman’s public key: