Can't create disposable VMs from template, that been restored from backup \ can't use restored dispVMs

I restored a backup in a fresh system, and AppVM’s I used as Disposable VM Templates - aren’t listed as “disposable” in qubes “Applications” menu (button in taskbar). Just as normal appVM’s (“Domain:” prefix, not “Disposable:” prefix).

But: original (installed by qubes installer) disposable VMs are listed and work fine. If I create new AppVM from one of the “original” “VM templates” and then mark it as “Disposable VM Template” - it works. But not from “new” “VM templates”.

Also, if I run qvm-run --dispvm=<restored disposable VM template> - works. And restored dispVMs\new dispVMs created from restored tempVMs are properly listed in some menus like “default dispVM template” global\per VM. But in-VM menus like “Edit\View in disposable VM” automatically chooses “original” dispVM.

I tried change installed_by_rpm pref of my restored “template VM” to True, but didn’t help.

Wtf. Some time have passed, I updated templates, got to work, and now VMs are correctly detected in a menu as disposable templates. Also there’s EVERY application available listed in VM’s submenu. Oh man… Okay.

Marked your reply as the solution since time solved it

Quoting from another thread: