Can't Connect to WiFi (Dell XPS 7590)

I am brand new to Qubes and after installing in live USB and booting up I cannot connect to my own ethernet or Wi-Fi. I am not super well versed in programming beyond copying and pasting terminal lines, so I don’t know how to solve this on my own. I am using a Dell XPS 15 7590. I have tried everything I could find on google, and nothing has worked so far. Any suggestions would be super helpful! I am sorry if this isn’t formatted properly, I am very new and am willing to provide any missing information as needed. Thank you!

Welcome to Qubes - I hope we’ll be able to get things working for you.

The first thing to check is that you have you network cards allocated to
sys-net - you can check this on the “Devices” page in the settings for sys-net.
In the Qube Manager, find sys-net and Right click to get to Settings,
or select the Settings button on the Menu bar.

Then, look for the Network manager icon - it’s the one that looks like a
bar chart - click on it and you should see entries for Ethernet Network
and Wi-Fi networks.
If you see your router in the list, click on it to connect.

If not, there could be a software problem. Make sure that sys-net is
running. If not, open a terminal in dom0 and try to start sys-net -
qvm-start sys-net - if it doesn’t start, you may see a useful

Open a terminal in sys-net and look at the logs to see if there are
any entries relating to those devices - it could be that you are missing
firmware that you need. Sometimes the log will tell you exactly what you
are missing, and how to remedy the problem.

Let us know what you find - and also, which version of Qubes you have


Thank you so much for responding! I have Qubes 4.0.4 installed and verified.
I found that there was a device called “3b:00.0 Network Controller: Qualcomm Atheros Wireless Network Adapter”.
But, I cannot find a “network manager” icon anywhere. I can, however find “Network Connections” in the system tools. I saw that in the Basic settings the “networking” drop down menu had (none)(current) as the selection (seen in the picture).

Also, I noticed that no matter what, I always have a red blank sys-net password window open when I boot up Qubes. Sometimes it will ask me for a “sys-net login” where it prompts me for a username and password that I don’t remember setting up.

If you know what I should try next that would be super helpful.

I loved this type of response. It gave me giggles about it.

It’s the same. You can right click on that icon, choose “About” and it should show that it’s “Networkmanager Applet”.

I opened that and a dom0 window opened that was labeled Network Connections, but nothing was there, and when I tried to “add” everything was greyed out and I couldn’t click on anything.

The network icon by default is on the top right of your screen, with the USB icon, the speaker icon, clock etc. It looks like some red steps. Do you have that?

In sys-net settings, go to the services tab and make sure that network-manager is active.

You can also go to the applications tab within settings and select the available networking application (move it to the right window). In my Debian version of sys-net it’s called “Advanced Network Configuration”. Then go to the Applications Menu on the desktop and open the networking app directly. That will bring up the same Network Manager window that right click → edit connections brings up from the system tray icon. This way you can confirm that it’s installed and running properly on your service VM. If it is, the problem is with the system tray. I have personally found the system tray to be buggy in my latest Qubes install.


Hey, I have a similar problem.

During trying to set up a VPN netVM or proxy I deleted all system trays by accident. I was able to find usb, clipboard and updater back but cant find the network tray.

Further I cant find a networking appication, neither in my sys-net nor my whonix. Before I was able to work with the tray (as Im a full qubes neewbie). I do can add the network manager as Service but afterwards i cant find the program itself.

Do you know where I find the network manager alternatively and how I can find my Network Tray back?

Thank you for your reply :slight_smile:

Well, I’d probably start from

[user@dom0 ~]$ qvm-run sys-net “pkill nm-applet; nm-aplet”

I found it back, thank you!

Great. How (important for other users)?

1 Like

A post was merged into an existing topic: Qubes-Air? Qubes in the cloud?

(edited title to be more specific about the issue)