Can't connect to ethernet for the first time

Hi,

I’m trying to connect to my router in order to set it up via lan, but can’t get even into router setup. When I search for the gateway ip with netstat -r -n or ip route, I get the same ip - 10.138.0.169 that hang for a minute when I try to connect to it via firefox on the sys-net VM and then it drops printing time out error. I’ve tried to setup my ethernet connection like so: sys-net > advanced network configuration > selected my device, on cloned MAC address tried all the options, MTU is on automatic and disabled ipv6. Am I suppose to do something else?

I also tried to connect to 192.168.0.1, 192.168.0.0, 192.168.1.1 without any success

Try going to the router login page using a different vm. fedora-36-dvm should be able to reach it.

So I need to reinstall the whole thing now? Is this knows that debian have issues with lan connection? I didn’t find anything in the docs

I just noticed it switches to https instead of http… I think that’s could be the reason I can’t access gateway with 0.0.0.0 And I can’t switch it off for some reason, in firefox it set to not force https, yet it auto correct it for the https instead of http

There’s no issue and you don’t have to reinstall “whole thing” whatever you meant on this. Start browser in any fedora/debian based dispVM which has browser installed in its template, and simply go to the IP of your router (192.168.0.1, or whichever it is - you simply has to know router’s address).

So I tried with adding firefox to debian-11-dvm and enter both 192.168.0.1 and 192.168.1.1 and it simply does not connect. For some reason it stays with https, not http… can this be the problem? I tried to force http changing the about:config settings check_doc_frequency etc and this didn’t help, it still redirect to the https version.

Switched the sys-net to fedora, disabled https… nothing helps. I can’t get to the router login page

I think it might be that I run RJ45 through type c?

Why both? What is the address of your router? Can you access it from some other device? Mobile phone?

Just in case and because that is what it says in the guide to the router. I don’t want to use my phone for that.

It’s not about managing your router from your phone, it’s about if you can access router’s login page. Otherwise, you’ll probably never know.

OK, so I’ve just installed kubuntu and without doing mambo-jambo, plugged the type-c-to-rj45 cable in and it connected, I then without doing anything hit the 192.168.0.1 and it just worked.

Now, what should I do with QubesOS in order for it to work correctly, I really suspect that it’s due to the fact I connect my networking cable with type-c.

Sounds like a USB-device (?) - was it connected, while you installed Qubes OS?

If it wasn’t connected when you installed Qubes OS: Which Qube did you assign it to, when you connected it to you machine? … and was it the same qube, where you ran

ip route

?

Note: the 10.138.x.x sounds like an internal network between qubes inside your machine - after click on “Q” → “Qubes Tools” → “Qube Manager” it looks like my system uses 10.137.x.x and 10.138.x.x … so it makes good sense that directing a browser towards 10.138.0.169 will hang - it would be a strange coincidence if you ran a webserver on your machine. :slight_smile:

1 Like