Can't boot QubesOS 4.2rc1

before installing the new 4.2rc1 on my computer I wanted to run some tests in a vm.
I know QubesOS is not supported to run in vmware workstation but it worked fine for me for testing.

I could install the new 4.2rc1.
It took some minutes until the install ui appeared.
After that I tried to boot the installed QubesOS.
But it gets stuck or crashes already in grub bootloader.
I can press enter key or e key there but after that the screen is frozen.

Does anyone have this issue?
What could I try to solve this issue?

qubes is fully supported in the vmware, it can pass thru vtx vtd.

its not clear in your statement, are you installing qubes in vmware or real machine ? if vmware have you try the uefi ?

thanks, that has solved the boot issue.
I had to create a new vm with uefi

Next issue I have is that I can’t start sys-net qube with the network pci device.
I have changed the vm to PV and added the qubes.enable_insecure_pv_passthrough

In libxl log I see: this device doesn’t support passthrough

Is pv passthrough not supported in the new version?
Any idea how to solve this issue?

Edit: Solved
qubes.enable_insecure_pv_passthrough solved the issue. Option was missing in grub.cfg

that is another question i think? create new thread for that.
also you can just use default settings, what you need is search on internet, how to enable vtx vtd in vmware.