Can't boot on Qubes (PXE-E61)


Right now, I can’t boot on my Qubes installation. I’m a bit lost on what to do…

When trying to boot, I get this message in something that looks like a BIOS screen :

Intel UNDI, PXE-2.1 (build 083) Copyright (C) 1997-2000 Intel Corporation

This product is covered by one or more of the following patents: US5, 307,459, US5,434,872, US5,732,094, US6,570,884, US6,115,776 and US6, 327, 625

Realtek PCIe GBE Family Controller Series v2.35 (06/14/10) PXE-E61: Media test failure, check cable

PXE-M0F: Exiting PXE ROM.

The last time I used Qubes, everything was ok, I just putted some files on a USB key … maybe I upgraded some qubes ?

Current hypothesis

Right now I’m trying something from the documentation page called UEFI troubleshooting… but I don’t know where to start.

My problem is that, after entering the rescue shell, choosing option 1 and typing my passphrase, nothing is mounted. I’m not sure where I can get /boot. I can mount /dev/sda1 and /dev/sda2:

  • sda1 contains a unique directory: EFI/
  • sda2 contains several files and a efi/ directory

So, maybe the content of sda1 is what is mounted under /boot/efi/ ? I tried the procedure Installation finished but “Qubes” boot option is missing and xen.cfg is empty / Installation fails with “failed to set new efi boot target” in the previously mentionned page but after selecting the Qubes option in Boot menu, I go back to this same menu, nothing happens.

Of course, I could try to reinstall Qubes on the disk and restore everything, but I would like to resolve this problem.

Less important things I already tried

I tried to search for a problem with the motherboard or the SSD disk but I think it’s quite okay. Except that, on the first boot, I saw that the BIOS had something strange because the date and time were completely wrong, so fixed it.

I tried to (re)enable/disable some options in the BIOS :

  • UEFI Boot
  • Launch CSM
  • Secure Boot Control

But I don’t remember how it was before ! I tried to rescue the system with a Qubes USB key. I choose the option 1) Continue (to mount my installation). I can decrypt the sda3 partition but then I get this message :

You don’t have any Linux partitions. Rebooting.

Please press ENTER to get a shell:

At first, I had no idea of what to do with this shell.

Some other things I tried :

  • run a SMART test: everything is okay;
  • decrypt and mount the data using a Tails system: it works;
  • put another SSD (with Windows) in the computer: I got the same error, but then, after missing with UEFI parameters I successfully started this disk;
  • install Qubes on another SSD: it works, I can boot on it;

So right now I think the hardware should be okay.

This guide is outdated and works only for Qubes OS 4.0.
The up to date UEFI fix is this one:


Awesome ! That’s the solution !

In my case, the exact command was:

efibootmgr -v -c -u -L "Qubes OS" -l /EFI/qubes/grubx64.efi -d /dev/sda -p 1