Can't boot, hangs on Starting Light Display Manager

I managed to install Qubes yesterday but noticed it was very laggy and only one of my screens worked. However, I managed to fix this by turning on iGPU Multi-Monitors in my bios. Immediately once I rebooted the lag was gone, my screens where in the proper resolution etc. All was good until my pc shutdown (power went out) while it was updating one of my templateVMs. I tried to reboot but it kept hanging on “Starting Light Display Manager”. I researched and figured it might be the drive that got corrupted or something. So I reinstalled Qubes but the same problem occured.

When I turned iGPU back off, it worked and booted again, but the lag came back. I then looked online and found the Nvidia Troubleshooting guide. I followed those steps while I had iGPU turned off and was able to edit the Xorg config to allow/turn on ShadowFB (I believe). However, now when I reboot with either iGPU on or off I get the same hanging problem and it never boots/gets to login screen.

My Xorg log says that no screens where found.

Any ideas or help would be appreciated. I am newish to Linux as well. In terms of specs, I have 32gb of ddr4 ram, I have VT-D and VT-X enabled, a RTX 2070 super. i5-9600k and a 500gb ssd. I also know it’s highly recommended to use integrated graphics, but I managed to get it to work with my gpu, I’m just not sure how lol

Thanks
I am also using legacy boot, not UEFI