Cannot run snap after upgrading

I recently did an in-place upgrade of my Fedora 33 templates to Fedora 34 using the process described at on Qubes 4.1. My Brave browser snap still worked after updating, restarting the VMs, etc. A few days later after doing some additional template updates, I can’t run my Brave snap. I have both snapd and qubes-snap-helper installed. This is the output I get from the terminal:

WARNING: cgroup v2 is not fully supported yet, proceeding with partial confinement
cannot perform operation: mount --rbind /dev /tmp.snap.rootfs_bnPFo2//dev: No such file or directory

I tried removing the snap and re-installing according to the instructions for snap installs listed on, but I get the same output. I get the same output with a different /tmp.snap folder name when trying to run ‘snap install chromium’ during the ‘Run configure hook’ part of the snap installation. The folder listed in the output is just an empty folder, and deleting that folder simply generates a new empty temporary folder when I try to run the snap again.

I am also sometimes getting startup errors on the VM in question like qrexec timeout errors.

Did you found a solution to this error?
I have exactly same error with a snap package. It’s working when installed, but it throwing the error when trying to run after restart the qubes later.

I’m not sure how I fixed it in this case. I have a lot of issues with snap errors after start/shutdown of VMs. Oftentimes, when the issue is related to Qubes adding the snap to the VM, restarting the VM a couple times or restarting my computer will fix it. Sometimes, the issue appears to be related to something in the VM rather than the snap being mounted during VM startup. I have had to manually remove and re-add snaps in this case. But you will need to restore your configuration if you do that.

For me, I can success remove/install hello-world.

snap install hello-world
hello-world 6.4 from Canonical✓ installed

snap remove hello-world
hello-world removed

But it triggers error for multipass

snap install multipass
error: cannot perform the following tasks:

  • Run install hook of “multipass” snap if present (run hook “install”: cannot perform operation: mount --rbind /dev /tmp/snap.rootfs_fG06vB//dev: No such file or directory)

snap remove multipass
snap “multipass” is not installed

So, the issue seems related to some snap packages, not all.