Cannot open/verify Detached PGP Signature 4.0.3

Step 3, Verify your Qubes ISO,, cannot verify ISO using Detached PGP Signature.

Result: gpg: can’t open ‘Qubes-R4.0.3-x86_64.iso.asc’: No such file or directory
gpg: verify signatures failed: No such file or directory

Running Windows 10, the filename is Qubes-R4.0.3-x86_64.iso.asc. Though, the filename under Properties – Details, the filename is Qubes-R4.0.3-x86_64.iso.asc.asc. Another way before, not changing filename, doing “Right-click – Save link as…”, the error above persists, Result. Troubleshooting FAQ says “The correct signature file is not in your working directory.” What is working directory? Where the files are stored/saved?
Running Kleopatra, this is the error: “An error occurred: Kleopatra: Could not open file […] /Downloads/Qubes-R4.0.3-x86_64.iso.asc” for reading: Input/output error (218136625)".

What is the issue(s)? Thank you.

“Working directory” = Whichever directory you’re currently “in.”

This usually applies to the command line, not a Windows GUI program, but it basically just means that the files must be in the correct place for whichever program you’re using to be able to find them.

That depends on you. Where did you save them when you downloaded them? Did you move them from the default save location?

I’m afraid I haven’t used Kleopatra in many years, so I can’t comment on the specifics of that program, but hopefully this helps a bit.

Files are in /Downloads/. After many attempts, no success opening/verifying with Detached PGP Signature. If you are unfamiliar with Kleopatra, do you recommend another program? Issue must be within file, Windows 10 doubling .asc.asc or Kleopatra. Thanks.

I just use GnuPG on Linux. If that’s available to you, I recommend it.

I’m not sure why that doubling would occur. Even if you download the file multiple times, I would expect [...].asc (1) or something. Maybe Kleopatra is adding the second .asc for some reason?

Must be a Windows 10 function causing .asc.asc. Even trying with the filename without .asc and with .asc (causing .asc.asc) the same error happens.

Also, it appears GnuPG is unavailable on 64-bit Windows. Do you know another alternative? Thank you.

Sorry, I’m afraid not. :slightly_frowning_face:

I use GPG4win which includes GnuPG

Gpg4win runs on Windows versions 7 or newer (up to Windows 10). Both 32 and 64bit systems are supported. If you have at least Windows XP, some parts of Gpg4win can be used, but are not officially supported.

That is what I am using, that is how I got Kleopatra. How did you work Kleopatra (or something else) for verification? Thank you.

Just tried it and it works (Win 10). I think your problem is with the extra ‘asc’ in the file name. Suggest you download the asc file direct from here - right click, save as https://mirrors.edge.kernel.org/qubes/iso/Qubes-R4.0.3-x86_64.iso.asc
Alternatively rename the file from cmd (open a command prompt (cmd),
cd C:\Users\[your-name]\Downloads
then
move Qubes-R4.0.3-x86_64.iso.asc.asc Qubes-R4.0.3-x86_64.iso.asc

Make sure the Qubes-R4.0.3-x86_64.iso file and the Qubes-R4.0.3-x86_64.iso.asc file are together in the same directory, then in Kleopatra click ‘Decrypt\Verify’ then select Qubes-R4.0.3-x86_64.iso.asc and after a minute or two you should see a success message (although it hangs at 100% for me sometimes).

Another way is from the command prompt: gpg --verify Qubes-R4.0.3-x86_64.iso.asc Qubes-R4.0.3-x86_64.iso which should give a message including “Good signature”

Renaming the filename in cmd appears to have worked partially. The error is now:
gpg: can’t open signed data ‘Qubes-R4.0.3-x86_64.iso’
gpg: can’t hash datafile: No such file or directory

Though, the Detached PGP Signature filename is Qubes-R4.0.3-x86_64.iso, with no .asc, yet under Properties – Details, it is Qubes-R4.0.3-x86_64.iso.asc. Therefore, the issue now appears to reside in the .ISO itself now? Unable to ‘Decrypt/Verify’ the file still in Kleopatra. The error is still “An error occurred: Kleopatra: Could not open file […] /Downloads/Qubes-R4.0.3-x86_64.iso.asc” for reading: Input/output error (218136625)".

Is the .iso (the 4.5 GB file) in the download folder too?

Can you use the command prompt? Make it easier to see what’s going on.

Edit: I see you are using it! Can you type dir and make sure both files are there and named correctly?

Yes. I see the error now. The .ISO file is iso.iso.

Is the command to rename it: move Qubes-R4.0.3-x86_64.iso.iso Qubes-R4.0.3-x86_64.iso?

Yes - that should work

1 Like

It worked! :smile: Thank you very much Plum for your assistance!

1 Like

No problem. Good luck with the installation!

1 Like

@abc, what browser are you using in Windows?

Just for further reference, Windows Explorer doesn’t show file extensions by default. That causes what might appear to be discrepancy between what you see in Explorer and what you see in the file’s properties. Explorer will show filename but right click/properties on the file will show filename.asc if it is a known file extension. If you have Kleopatra installed, .asc will be a recognized extension.

Second, verifying detached signatures expects the source file data to be the filename of the detached signature minus the .asc (or .sig) at the end. So if the detached signature filename is sourcedata.iso.asc, the file with the data to be verified is assumed to be sourcedata.iso.

I suspect the issue here is why the downloaded files are [qubes].iso.iso and [qubes].iso.asc.asc. Were the files ever renamed after download?

When clicking ‘Save As…’ to download the files, there should be no need to rename; just hit the Enter button. Assuming you have not changed Explorer settings to show file extensions, the file save dialog will not show .iso or .asc. If you didn’t rename upon or after downloading, what browser did you use?

This isn’t a Windows forum, but I would suggest disabling the Hide Extensions option in Explorer. It’s a common vector to cause confusion and coerce someone to click on an executable file even though it might have a .txt extension. For example, Important-Document.txt.exe will show as Important-Document.txt in Explorer.

Firefox.

Kleopatra has struggled with .asc files thus far.

Yes and no, after tries.