Cannot Launch Terminal from Applications Menu after distro-sync of the Fedora-33 template to Fedora-34

This seems to be an easy fix with xfce, but the answer allludes me.
It seems to be a broken association specific to the Applications Menu since gnome-terminal can be started using other methods within the template.

The fedora-33 template was upgraded to Fedora-34 using:
Within a dom0 terminal:
[qtech01@dom0 ~] qvm-shutdown fedora-33
[qtech01@dom0 ~] qvm-clone fedora-33 fedora-34
[qtech01@dom0 ~] qvm-run -a fedora-34 gnome-terminal

Within the newly opened terminal:
[user@fedora-34 ~]$ sudo dnf clean all
[user@fedora-34 ~]$ sudo dnf --releasever=34 distro-sync --best --allowerasing

The fedora-34 template seems to work as expected with the quirk that the Terminal cannot be started from the Applications menu.
The Terminal can be started from:
a context menu in gnome Files
the dom0 terminal using: qvm-run -a fedora-34 gnome-terminal.

The terminal still opens from the Applications Menu in the fedora-33 template.
The terminal doesn’t open from the Applications Menu in the fedora-34 template.

The org.gnome-Terminal.desktop files in ./local/share/applications and /usr/share/applications are identical between the two templates with the exception of the fedora template name change from 33 to 34.

The following commands were run in a dom0 terminal with no remedy:
qvm-sync-appmenus
qvm-appmenus --update --force fedora-34

~/.config/menus/applications-merged/fedora-34-vm.menu
does show an entry for org.gnome-Terminal.desktop

Before travelling to much further down the rabbit hole, it’s probably a good time to ask for suggestions and verify that this can be corrected since fedora-34 isn’t supported yet.

I think fedora-34 isn’t ready yet, I’ve try too but still have so many unsupported.

It would seem to be an easy fix for someone better versed at xfce app menus within qubes than I.
Thanks for your feedback.

have tested it today, it’s work well.
don’t forget to enable current testing repo in template.