Cannot connect to wifi (a lesson in networking on Qubes OS)


I recently purchased a Librem 14 (or 15) from Purism that came pre-installed with Qubes OS. I am not finding any tickets/issues on their website, so I’m wondering if you have received similar reports. Could be a hardware issue with the wifi adappter, but I think it’s more likely a router setting.

(Of course don’t trust me I have no idea what the issue is)

After the first boot, I am unable to connect to a network (read: all settings in Qubes OS 4 are default). I have two networks at my house, different router/modem configurations, and I received access (though now nothing) on one yesterday briefly, and nothing on the other, ever. No settings have changed.

Typically what is happening is the connection is timing out. Wheel spins, and then there is an error that I have been disconnected (nondescript error that I assume is a timeout).

In some cases, I’ll get an error of an interface mismatch (between the profile in sys-net and the router).

Sorry I do not have the exact error message, but that is directly the information that I get. I’ve tried searching the errors, and I cannot find information.

Upon looking at the sys-net and sys-firewall set up, everything is out of the box. sys-firewall is NetVM, sys-net is the networking on sys-firewall, and sys-net has no networking. Both the wifi card and ethernet adapter are added to sys-net under devices.

Also I have tried toggling the wifi adapter kill switch. I have updated dom0 and a few templates. I do get internet access through the ethernet cable.

Any advice? Is there a command I can run in the sys-net qube that will read out the connection attempt log so I can see what it’s getting hung up on? Based on the “interface” mismatch error, is there a way to set the interface in sys-net?

You’re a star

Also, just wanted to express that I’ve read through many of the Qubes docs and forum threads. The community here is great, and I’m happy to be part of it! Look forward to paying it forward

Quick update,
I’m not sure if this is normal of Qubes OS or is specific to the PureBoot from Purism. But after I encrypted the disk the first boot, and now after updating dom0, the list of boot entries changed. I believe this would be in the grub directory. In any case, I tried a new one; Qubes with Xen Hypervisor, as opposed to Qubes with Xen -{some version number} and Linux {some version number}, and I was able to connect to one network instantly. I understand that Xen has something to do with networking, but I don’t know much about it yet. I’m also not sure what the default boot should be… but for now it’ll be the one that gets me on the internet!