Cannot boot virtual machine "Could not read from CDROM (error 4)"

Hi, I am a new qubes user. I have tried creating new standalone virtual machines from several different ISOs (windows and linux) and each time it goes to start I get:
Booting from DVD/CD…
Boot failed: Could not read from CDROM (code 0004)

Right now the iso is sitting in the downloads folder of my personal drive. I think this this is something machine or BIOS related because after I could not get Qubes to work, I tried to do virtualization in unraid and got the same errors when booting from a VM (dockers appear fine). I have already asked the unraid community for suggestions as well:

Been trying both OSes for over a week and cannot get working…so open to suggestions. I know HVM and IOMMU are on because it shows it as such from the info panel. The motherboard is a ASUSTeK COMPUTER INC. ROG CROSSHAIR VIII HERO (WI-FI) Version Rev X.0x with BIOS BIOS American Megatrends Inc. Version 1302. Ryzen 3950 processor 128 GB ram. Everything else appears to be working in Qubes except being able to boot from ISOs to create a new virtual machine.

Thanks in advance for your help.

Hi @WorldTraveller,

did you follow the StandaloneVM documentation?

  • If yes, on which exact step it failed for you?
  • If no, please try with this documentation.

Note that you can also create a StandaloneVM from a TemplateVM.

Thanks for your help.

I actually had not seen that page, but had used the GUI as briefly described there on that page as opposed to the command lines. It stalls when it goes to boot with the CRDOM (code 0004) error described above. That would correspond to the step qvm-start on the command line. I actually tried that instead of starting from the GUI (qvm-start my-new-qube --cdrom=personal:/home/user/Downloads/AME.iso) and essentially got the same error. I get a message that the ISO is available. Then a message that the domain is starting and then the domain has started, with the CRDOM (code 0004) error that it could not read from CDROM that I got before.

I also tried starting from scratch on a new VM and just using the command line - qvm_create and qvm_start. That gives me a different error. It outputs: “Booting from ROM…” with a slight delay then “Probing EDD (edd=off to disable)…ok” and then another slight delay, and then the system halted, I am assuming because there was some parameter I needed to enable on the command line to get to work. I went back and edited the Qubes Settings from the GUI to make sure enough memory and hard disk space was provisioned, etc., as I figured that not being specified on the command line was the problem. When I do that it gives me the same CDROM 004 boot error as above when I just used the GUI.

I tried going back into BIOS to change from Legacy (which I needed to get Qubes installed from the USB in the first place) to UEFI and I run into the same snag.

Note that I never created a VM from an ISO… So maybe others will give better advises…
You tried a MS-Windows ISO (AME.iso), I 've seen a lot of posts about MS-Windows VM, search in this forum.

Yeah thanks for your help. I mainly want to create from ISO to install windows (probably will use the Windows ameliorated edition to cut out all the absurd spyware in it) as there are programs you just cannot use in linux. I followed all the instructions I see on Youtube and online … just same procedures do not seem to work on my computer.