Can’t find the network manager, sys-net doesn’t work

Hello Qubes users!
I spent too much times to find the issue but maybe i am just too noob for finding the answer.

Here is my problem:

I installed Qubes on my Dell 5420 I5, and i was wondering why i can’t find the network manager and why my sys-net doesn’t work.

When i type qvm-start sys-net in the domO terminal : i got this :

Qubes sys-net has failed to start: internal error : unable to reset PCI device 0000:00:1f.6no FLR, PM reset or bus reset available

I used the latest version of Qubes 4.1.1, i havn’t choose the option “test media and install qubes”

i tried the lspci command to see which one is concerned and it’s related to my intel ethernet controller.

What i have missed? ( i am sure a lot lol)


Try loading a Live USB of any major non-free distro and confirm that the Wi-Fi or Ethernet connection works. This is to exclude hardware fault.

i can give more details if it can helps :slight_smile:

i downloaded the iso from here :

I used Rufus to burn the iso to a usb. then i installed the iso in DD for more stability.

Then i loaded the iso on my ubuntu os based.(wifi was turn on but i havn’t tried yet with non free distro)

and i first tried the option : try media and install Qubes4.1.1

Did you check dmesg for any errors?

If you are missing the driver or firmware for the network interface you are not going to be able to start sys-net, the network interface is passed to sys-net if it fails to initialize the vm is unable to boot.

i checked dmesg and Oh My God there is so much red and green everywhere!

Don’t forget that i am a noob !

humm when i was on debian11 i needed to install iwlwifi to have internet

Start with checking the devices tab in the sys-net settings, if there are any unknown devices you might be able to remove them a start the vm.

In dmesg look for any errors relating to the wifi or wired network, it might just be one of the two that isn’t working.

i can’t have access to my devices tab in sys-net settings… It’s the only one unavailable…

Make sure the vm isn’t running, you can’t change the device settings unless the vm is off.

VM for virtual machine ?

Not this time, i try to launch Qubes as my principal OS.

(first time i use Qubes)

@bvc69 I suggest you read through the documentation here:

From the info you’ve given here, here’s what I can recommend you try:

  1. ensure sys-net is off (to do this run cmd in dom0 terminal: qvm-kill sys-net)
  2. Open the Qube Manager, go to sys-net right click properties and click devices:
    Make Sure that the devices attached to the qube are only wifi or ethernet devices - this will be named something like ‘intel wireless …’ ‘realtek …’ DO NOT attach any other devices, as you will get errors.

Apply the settings
3) Try turning on sys-net
If the issue persists, please read:

and follow the steps there.

  1. Please reply here to let us know whether you have fixed the issue or not.

oh thank you for the documentation! I will keep you in touch if i succeed after the reading

Edit : I got this previous message before finishing the installation.

1 Like

Made the title more helpful for other users

thank you fsflover!

@bvc99 Can you clarify, is the PCI issue fixed now?

Where did you get the ISO/qubes-image from? Did you verify the signature?
How many times did you try to install the ISO? Given the initial configuration failed I’d advise you to try installing again and see if the error re-occurs; if it does then it is worth further investigation and a bug report on

i downloaded the iso from here :

(i havn’t verified the signature…)

I tried at least 7 times to install the ISO… sometimes it does’nt restart automatically during installation.

Maybe my computer doesn’t have the requirements for Qubes?

Do you think it can be related?

here is my configuration for virtualisation

sorry for the low quality image ^^

it seems that my computer can run vt-x virtualization

It’s definitly my installation that cause the fact that i can’t connect to internet. I use Rufus i choose the right option i don’t know why it won’t work… Change of usb key can eventually help me ?

If you don’t answer on other’s questions and tips. no help…

Did you try something like:

qvm-pci attach --persistent sys-net dom0:00_1f.6 -o no-strict-reset=true

i am so sorry if i missed some questions or tips, i know i came here for asking help and i don’t want to be rude. Guys in this forum are so helpful!

enmus : i tried your command but it doesn’t work (thanks btw) do you want the return command?

If i try to install qubes on a usb key, do you think i will be able to be connected to internet after the installation?

1 Like

@bvc99 can you please confirm you followed the steps above:

If you have, please inform us of any errors at each step.

@Quser59 I can’t follow your instructions because after my installation, sys-net is disable by default.

Look my qubes manager

And when i try to acces to sys-net settings :

i can’t acces to devices…

But when i try to turn on sys-net i got this error

so i read the PCI troubleshooting | Qubes OS

i tried this command in the terminal dom0

qvm-pci attach --persistent --option permissive=true --option no-strict-reset=true sys-usb dom0:<000:00:1f.6> ( i tried one of the options and both)

But nothing happens…

and i failed to list pci devices with qvm-pci…

(thanks for the documentation btw!)

That command won’t work as you’ve specified sys-usb, not sys-net.

In a dom0 terminal, run the command:

wait for the output. You will see your wireless device, if it is attached to a VM it will specify this in the right hand column.

Copy the device name dom0:xxx.
If the device is attached to a VM, run:
qvm-pci detach VM dom0:xxx

then run the command:
qvm-pci attach --persistent --option permissive=true --option no-strict-reset=true sys-net dom0:xxx