Can no longer setup Qubes when I was running it perfectly fine 3 days ago


About 3 days ago I decided to do a fresh install of Qubes, simply because I wanted to change my disk password and re-installing it seemed easier then messing around with grub. This was a grave mistake.

I used the exact same setup-USB that I originally installed Qubes on 6 months ago or so, running 4.2rc3-iso (I was simply going to update through Qubes). For no reason at all, after installing it, TOR refused to connect and stayed at 5%.
After some research I decided it was something to do with the system clock in the BIOS, (it was an hour off due to daylight savings) so I changed it. After also messing around with sys-net, I somehow broke it and it refused to even connect to any router, so I can’t even test if my fix worked or not. “I’ll just re-install it again” or so I thought.

After re-installing again, this time, sys-net works of course, but I now have a brand new error which is simply whonix refuses to work, at all. At the end of the installation I get:

[‘systemctl’,‘start’‘qubes-vm@sys-whonix.service’] failed:
stdout: “”
stderr: "Job for qubes-vm@sys-whonix.service failed because the control process exited with error code.
See “systemctl status qubes-vm@sys-whonix.service” and “journalctl -xeu qubes-vm@sys-whonix.service” for details.

Worth noting I put that last statement into the terminal, and it always spits out “job failed” with a random job identifier number every time. I’ve re-installed 3 times now and this error has spit out at the end of the installation every time.

I’m actually running it of USB, so to make matters worse, installing is a genuine 5+ hour process before it’s done, and I only know it failed at the end. My last attempt I actually grabbed the most recent stable 4.2 iso incase it was something to do with it being 4.2 pre-release rc3, but I still get the same error. I can’t launch anything related to whonix, including anon connection wizard, and I don’t want to update/connect qubes through clearnet.

I’m at my wits end. All I did was change the BIOS time one hour back (I know for a fact I didn’t change anything else, as much as it seems like I did) and now I can’t even use Qubes. Changing it forward dosen’t fix it either. Any help pretty please.

Did you test installation media before installing Qubes OS to ensure that the Qubes OS installer image was written to the installation media correctly?
There is a default installer GRUB menu entry for this:

Yea, I did and, okay it fails, but I already looked this up and apparently it always fails if you made the USB with rufus on windows (which I did). As I mentioned, I’ve already used this USB for my original installation - the exact same files, I haven’t written to the drive - so it would be highly unusual to fail after only a few months of inactivity. I’ll try and use a different USB, but I don’t expect this to be USB problem to be honest.

Maybe there is just not enough free space at your installation destination so Whonix templates weren’t created correctly.

It’s 64gb, there should be enough space. Oh well, guess I’m going to have to switch to manually running whonix on linux or tails or something at this point.

Have you tried recreating the installation drive on the Qubes install? from my understanding the only thing wrong is the Whonix, not the other networking.

Also, have you tried reinstalling Whonix? You can delete all whonix-related qubes, reinstall the templates, and you can get sys-whonix back with dom0$ sudo qubesctl state.sls qvm.sys-whonix.

You can try to find the exact error that is causing sys-whonix to fail.
Run this command in dom0 terminal:

journalctl -f -n0

Start sys-whonix.
Check the log output in dom0 terminal after sys-whonix will fail.
Check the sys-whonix log in /var/log/xen/console/guest-sys-whonix.log.