Can I Delete Whonix-ws-15 gw and ws After Installing Version 16?


I’m running Qubes 4.0 I’ll be installing 4.1 in 3 or 4 months.
I’ve installed whonix 16 gw and ws alongside whonix 15 as indicated by Qubes manual, both whonix 16 gw and ws are working.

I would like to clean things up a bit and also stop Qubes updater from asking me to update whonix 15 ws and gw,
Can I deleat whonix 15 gw and ws using Qubes manager, or can this deleation cause damage to Qubes.

Just delete Whonix 15 WS and GW becaue they didn’t cause any damages. Also change all whonix qubes to whonix 16 templates.

Thanks for reaching out to help.
I’ve fallowed your instructions to delete gw-15 and ws-15 via Qube manager and delete qube, I keep on getting [Dom0] error removing Qube. VM installed by package manager:whonix-gw-15
Same with Whonix-ws-15.

sudo rpm -e qubes-template-xxx

From Dom0 terminal I entered
sudo rpm -e qubes-whonix-gw-15-xxx
error: package qubes-whonix-gw-15-xxx is not installed
I also tried
sudo rpm -e qubes-whonix-gw-15
sudo rpm -e whonix-gw-15-xxx
sudo rpm -e whonix-gw-15

sudo rpm -e qubes-template-whonix-gw-15
sudo rpm -e qubes-template-whonix-ws-15

Once again, thank you for your support, I’tried the command line, and received a warning.

Please try to describe instead posting pictures. Some people don’t want to open them for security reasons, or they do not load them (mail users, for example).
No VM can use template in order it could be deleted. So, either delete those dvm’s and all other VMs based on -15’s, or point them to something else, -16’s for example and then try to delete it.

If that doesn’t help, try this

The Wiki is very complete ans always has the answer. Are you following these instructions?

If you’re having issues with it, please submit the bug / difficulty question at their forum instead.

also, I’ve edited the topic title for clarity

1 Like

thank you for your direction deeplow, referring to the manual is aiways a great idea, it’s a good lesson for me, thank you.

1 Like

All is good with removing whonix 15, whonix 16 is working and in good order, I never would have thought that whonix would provide that kind of support, needless to say there’s a very strong community out there and I’m just starting to recognize at a deeper level, how github, Qubes, Whonix, Debian, Fedora, Ubuntu, and all the other linux based O.S’s support each other. This is an increadibile example of people caring and helping others, the common goal is simple yet complex, VERY UPLIFTING, THANK YOU.

1 Like

The edited topic title is appreciated, I do well with technical writing, I guess when I’m struggling with understanding content I don’t write as well.

1 Like

I believed that since I was working with Qubes os that this would be a qubes related forum question, realizing more clearly now that this is whonix installed on a VM which is installed on Qubes.
I’m fairly new at using Qubes and VM’s.
I appreciate everyone’s patience and support.

1 Like

No worries, we’re here to help navigate the waters. Coming to an new operating system one doesn’t expect it to be instead a meta operating system. Even if we know that qubes is kind of like that, it takes a while to realize what subcomponent we are using and the right place to get support. We’ve all been there!

And welcome to Qubes OS :slight_smile: