Bug: KDE virtual desktop "leaking" (intra VM)

I am currently running the latest 4.1 testing release with KDE.

I encountered unusual behavior while dragging a folder from one file manager window to another Everything occurred within the same VM. Multiple attempts to drag and move the folder failed. i.e. I dragged and dropped… but the source and destination directories remained the same. I eventually had to right click “move to…” and it worked.

A few minutes later, I switched to another virtual desktop and noticed that the text editor (from the same VM) had an error that included the path of the folder I attempted to move. It was complaining that it’s a directory. It’s the same error that gets thrown when dragging a folder into a gedit window.

It seems that the virtual desktop where I was moving the folder was “seeing” the text editor on top of the destination file manager window even though the text editor was on another virtual desktop. The text editor window was in the same relative screen position but on a different VD.

The same behavior persisted regardless of the which virtual desktop contained the text editor (I have five desktops). Likewise, I was able to successfully drag and move the folder if I moved the text editor out of the same relative location as the destination file manager window on its respective desktop.

In terms of reproducibility, I had the text editor and one file manager window open long before I used ctrl+N to create a new file manager window to quickly move a few files. That might have contributed to the behavior.

Hope that makes sense. Definitely a bug, not a “feature”. :slight_smile:

Oh yeah, I don’t have a git account so I am unable to report the bug via the usual channels. Perhaps someone can pass this along to those it may concern. Thanks.

It is a bug, but not a Qubes bug.
It seems to be triggered if the “lower” window has focus on its desktop

  • if you remove focus (by e.g. clicking on the desktop) and then switch
    desktops, the behaviour doesn’t occur.
    I’m fairly certain of this: perhaps you can confirm?

It still occurs. It seems that the only way to get it working properly is to focus on the destination file manager window prior to dragging from the source file manager window. Once it’s working, the only thing that will getting it not working again is to focus on the text editor window. Once it’s not working, unfocusing the text editor window by clicking on the text editor desktop isn’t enough to get the drag function working in the file manager windows. Hope that’s clear. You might want to give it a try.

That doesn’t seem to be my experience.
No matter - it’s annoying however it occurs. (I’m not a great user of
drag and drop so have not encountered this myself.)

I’m not too concerned about it… as long as it’s intra VM!