Broken microsoft Teams in qubes? (web version)


I’m just curious, I had to join a Teams meeting, I used the web version in chromium, but when joining I got an error that I couldn’t join. I tried 5 seconds later on a regular Linux system and it worked.

Is Microsoft Teams incompatible at all now? I guess they need webgl or something stupid…

I’m not sure what the issue is, but indeed recently it doesn’t work in Chromium (I think it worked before). But it does work in Firefox.


I didn’t try on Firefox, last time I got a message that Teams was explicitly forbidden on Firefox :laughing:

I should have tried, or even fake the user agent because this used to work too…

Were you using Chromium on Debian?

I noticed that there is a piece that the Debian team explicitly disables in their Chromium build that breaks… I think it was Zoom for me. I suspect that could affect Teams as well.

I’ll find you the link to the explanation in the Debian bug tracker, I don’t have it handy now but kept it for future reference. If you were not using Debian of course, this hypothesis falls apart.

I was using chromium on Fedora.

Upon connection, I had a message “sorry, we couldn’t connect you” (not the exact message, I translated it from my language). ¯\_(ツ)_/¯

No luck then. I don’t know.

Off-topic follow up on Chromium / Debian Just not to let vague allegations floating around: the issue I encountered had to do with screen sharing on Google Meet (not Zoom).

And the explanation is here:

The reasons for disabling that feature on Debian’s side probably sum up to: too much work to maintain a patch that cuts Google tracking while allowing screensharing. (That’s how I understood it at least.)

None of this is specific to Qubes OS.

Broken teams? :))
None of these things.
Microsoft deliberately allows all the benefits of Teams only in the Microsoft Edge browser, which is also available on Linux.

The Edge browser is also required, for example, to export various reports from M365 (it displays such a message when you try to download any report).

In addition, on Windows10 / Windows 11 (HVM) it is impossible to launch the teams.exe application for several months - a blank white screen is displayed instead of the interface.

The problem occurs on any HVM with clean Windows.
Monopoly is doing its job :slight_smile:
Microsoft Edge, after all, even has an exclusive plug-in that allows you to watch Netflix in 4K resolution

It works perfectly. I tested Teams in Google Chrome in Debian. Web version. It will request a Progressive Web-App add-on to Google Chrome.

1 Like

I must have had some shenanigan in the network :slight_smile:

Some time ago I had success in changing the user agent to edge.

1 Like